Support Offline : Mon - Fri / 10am - 6pm (GMT +6)

Your Time: Our Time:

SP Page Builder not updating Home Page

Featured Lock Resolved Issue
I have link my Home menu with my SP Page Builder Home page. But the changes I've made on SP page Builder even after saving it has not been updated on my home page when I go to preview. I'm currently testing on a local machine. Can anyone assist me in fixing this problem?

6 Answers

Rashida Rahman - Staff

2 weeks ago #Permalink
Hi,
Please clear your Joomla and browser cache and try again.
And Please check that which menu is active in your site from template settings, you should choose your desired menu there.
To check that please go to Extensions>templates>styles
Then click on your default template name that you have star marked and go to Template Options.
And find there Navigation:
https://prnt.sc/pzhhnp
Find or choose your desired menu, which menu's Home menu item you have linked with the Home Page.
https://prnt.sc/pzhivg

Hope these helps

Best Regards
Thanks Rashida for your reply. I followed your instructions completely. But I still have the same problem. I even tried it with different templates. I have my page built in Sp Page Builder but I just can't see it in the preview.

Rashida Rahman - Staff

2 weeks ago #Permalink
Thanks Rashida for your reply. I followed your instructions completely. But I still have the same problem. I even tried it with different templates. I have my page built in Sp Page Builder but I just can't see it in the preview.


Hi
Difficult to predict. would you please give me your admin access through PM, if possible?
I will try to find out your issue.

Note: To PM me please click on my avatar and find the send message option.

Regards
Thanks Rashida for your reply. I followed your instructions completely. But I still have the same problem. I even tried it with different templates. I have my page built in Sp Page Builder but I just can't see it in the preview.


Hi
Difficult to predict. would you please give me your admin access through PM, if possible?
I will try to find out your issue.

Note: To PM me please click on my avatar and find the send message option.

Regards


I am currently testing on a local machine using Wampserver. Not sure if this might help but I have multiple languages installed on the site. Also when I click on preview in Helix it goes to the main page without the updated changes. But when I click on the frontend editor i get a 404 error.

Rashida Rahman - Staff

2 weeks ago #Permalink
Hi,
Here is a tutorial for multilingual website:
https://www.joomshaper.com/blog/step-by-step-tutorial-for-creating-a-multilingual-joomla-site

You have to duplicate your template for each language and have to create different menus too and assign them within the right template through navigation/menu option.

And about 404 error, you can try disabling the SEF settings and rename the .htaccess file to htaccess.txt.
https://prnt.sc/pt7n4g
https://prnt.sc/pt7npp
But I feel if you clean up your multilingual issue then problems will be solved.
As I said before you can PM me your credentials so I can check those.

Regards
I uninstalled everything and installed the quickstart. I got everything I need when I did this. thanks for your help


There are no replies made for this post yet.
Be one of the first to reply to this post!

Leaderboard (30 days)

Paul Frankowski

Paul Frankowski

Total Accepted Answers: 105
Toufiq

Toufiq

Total Accepted Answers: 61
Sifat

Sifat

Total Accepted Answers: 44
Rashida Rahman

Rashida Rahman

Total Accepted Answers: 17
Mehtaz Afsana Borsha

Mehtaz Afsana Borsha

Total Accepted Answers: 17

118

Templates

305946

Community Users

Newsletter

Don’t miss any updates of our new templates and extensions and all the astonishing offers we bring for you.
We never spam

Joomla! ® name is used under a limited license from Open Source Matters in the United States and other countries. JoomShaper.com is not affiliated with or endorsed by Open Source Matters or the Joomla! Project.

Connect Us