Support Forums

Support Offline : Mon - Fri / 10am - 6pm (GMT +6)

Your Time: Our Time:

SP Page-builder Tabs and Accordion not working

Featured Lock Resolved Issue
Neither Tabs nor Accordion are working in SP Page-builder. I can create the tab or accordion, but when I go to preview the changes, neither are visible on the page. I recently upgraded to SPPB 3.2.9 pro.

I am also getting this error when I try to load images in the SP image gallery add-on form SPPB

[repetable_item full="images/2018/09/04/p222-4679-check-out-our-pits-ii-021718-013.jpg"][/repetable_item][repetable_item full="images/2018/09/04/p222-4679-check-out-our-pits-ii-021718-146.jpg"][/repetable_item][repetable_item full="images/2018/09/04/p222-4679-check-out-our-pits-ii-021718-110.jpg"][/repetable_item][repetable_item full="images/2018/09/04/p222-4679-check-out-our-pits-ii-021718-035.jpg"][/repetable_item][repetable_item full="images/2018/09/04/p222-4679-check-out-our-pits-ii-021718-026.jpg"][/repetable_item]

18 Answers

Paul Frankowski - Staff

More than a month ago #Permalink
Hi,
Read tip "Addon settings or design problems"
from: https://www.joomshaper.com/documentation/sp-page-builder/sp-page-builder-3#faq-problems-solutions

I am pretty sure that it's problem with your template.

Michael Weaver

More than a month ago #Permalink
Hi,
Read tip "Addon settings or design problems"
from: https://www.joomshaper.com/documentation/sp-page-builder/sp-page-builder-3#faq-problems-solutions

I am pretty sure that it's problem with your template.
Hey Paul, Thanks for getting back so quickly. I read the article and went through the steps. Cleared the cache, reinstalled, check to see if the licenses are up to date, et al. Unfortunately I am still having the same issues. with Tabs, accordion and gallery... although the error did change some what to [repetable_item title="Item 1"][/repetable_item][repetable_item title="Item 1"][/repetable_item][repetable_item title="Item 1"][/repetable_item]. Included is an example of the gallery error.

Additionally... none of the SPPB addon's are working. I just tried to add 'pie progress' and I got the following error:

[repetable_item title="Set1" image1="images/2016/08/30/blurred-background-office.jpg" image2="images/2016/08/30/about_us.jpg" image3="images/2016/08/01/home2_girl.png"][/repetable_item][repetable_item title="Set1"][/repetable_item][repetable_item title="Set1"][/repetable_item]

Google maps is blank.

Person seemed to work ok.

Progress bar worked.

Staff gives me this error
[repetable_item title="John" title_color="" last_name="Doe" last_name_color="" designation="CEO/Founder" website="" content_title="Few Words About Me:" content_title_color="" content="Anim pariatur cliche reprehenderit, enim eiusmod high life accusamus terry richardson ad squid. 3 wolf moon officia aute, non cupidatat skateboard dolor brunch. Food truck quinoa nesciunt laborum eiusmod. Brunch 3 wolf moon tempor, sunt aliqua put a bird on it squid single-origin coffee nulla assumenda shoreditch et." skill_bar_color="" skill_bar_inactive_color="" skill_text_color="" skill_bar_height="" skill1_title="" skill1_percent="" skill2_title="" skill2_percent="" skill3_title="" skill3_percent="" skill4_title="" skill4_percent="" icon1="" icon1_url="" icon2="" icon2_url="" icon3="" icon3_url="" icon4="" icon4_url="" image="images/2018/09/04/0.jpg"][/repetable_item][repetable_item title="John" title_color="" last_name="Doe" last_name_color="" designation="CEO/Founder" website="" content_title="Few Words About Me:" content_title_color="" content="Anim pariatur cliche reprehenderit, enim eiusmod high life accusamus terry richardson ad squid. 3 wolf moon officia aute, non cupidatat skateboard dolor brunch. Food truck quinoa nesciunt laborum eiusmod. Brunch 3 wolf moon tempor, sunt aliqua put a bird on it squid single-origin coffee nulla assumenda shoreditch et." skill_bar_color="" skill_bar_inactive_color="" skill_text_color="" skill_bar_height="" skill1_title="" skill1_percent="" skill2_title="" skill2_percent="" skill3_title="" skill3_percent="" skill4_title="" skill4_percent="" icon1="" icon1_url="" icon2="" icon2_url="" icon3="" icon3_url="" icon4="" icon4_url=""][/repetable_item]

Attachments (1)

  • Capture.JPG
    Capture.JPG 77.1 KB

Paul Frankowski - Staff

More than a month ago #Permalink
Are those Addons are ours?
If you're not sure, please make a simple test, install Helix3 template and switch as default, and again check front-end.
If will be okay, it means that you have to delete broken addons folders from your current template folder !

Michael Weaver

More than a month ago #Permalink
I am running SPPB 3.2.9 and the the latest version of helix. The addons I circled are the ones I need and are the ones which are not working. These came standard with the SPPB along with the helix addons with the template and did work prior to the update. See attached.

Attachments (1)

  • sppb.JPG
    sppb.JPG 93.8 KB

Paul Frankowski - Staff

More than a month ago #Permalink
the last marked addon on your list is not ours.
----

I am asking again,
1) are Tabs and Accordion addon overridden in your template ?
2) template name & from which developer you have it?

show me screenshot content of this folder:: templates\shaper_NAME\sppagebuilder\addons

Michael Weaver

More than a month ago #Permalink
As to licensing, the tabs and accordion worked fine before the SPPB update. The template I am working on would be under the SPPB pro license... not the Template Developer license.

Here is the screenshot of the directory sppagebuilder\addons\ here are the contents

Also I temporarily changed the names of the folders to avoid some of the page errors - even with the correct folder names "accordion" and "tab" it still doesn't work.

Attachments (1)

  • folder.JPG
    folder.JPG 224.6 KB

Michael Weaver

More than a month ago #Permalink
As to licensing, the tabs and accordion worked fine before the SPPB update. The template I am working on would be under the SPPB pro license... not the Template Developer license.

Here is the screenshot of the directory sppagebuilder\addons\ here are the contents

Also I temporarily changed the names of the folders to avoid some of the page errors - even with the correct folder names "accordion" and "tab" it still doesn't work.
With the "accordion" and "tab" directories names changed back, instead of getting a blank area on the page - I get the following (which is why I changed the names)

Attachments (1)

  • dsa.JPG
    dsa.JPG 82.2 KB

Paul Frankowski - Staff

More than a month ago #Permalink
Do you see difference between word "DELETE" addon folder and "RENAME" addon folder ?
:( :( :( :(


*Delete was in our Manual !!

Paul Frankowski - Staff

More than a month ago #Permalink
You have tons of addons there, probably 60% of them were written to work with SPPB 2.x only.

Michael Weaver

More than a month ago #Permalink
Yes. I will delete again per the manual. The rename was just a "hail mary" after the reinstall of SPPB. and no I am not a developer, ours took a job with IBM - so I am just trying to get this finished for the client and the stupid thing to work. After deleting folders I still have the accordion and tab folders I still have the same problem.

Michael Weaver

More than a month ago #Permalink
Yes. I will delete again per the manual. The rename was just a "hail mary" after the reinstall of SPPB. and no I am not a developer, ours took a job with IBM - so I am just trying to get this finished for the client and the stupid thing to work. After deleting folders I still have the accordion and tab folders I still have the same problem.
I deleted... went into SPPB... added tabs, saved and it doesn't show up.

Attachments (3)

  • 1.JPG
    1.JPG 101 KB
  • 2.JPG
    2.JPG 70.7 KB
  • 3.JPG
    3.JPG 99.1 KB

Paul Frankowski - Staff

More than a month ago #Permalink
Can you add now "new" Tabs or Accordion addon into page, please check.

Michael Weaver

More than a month ago #Permalink
My apologies for being the ID10T error of the day... but still no change - see screenshot progression history

The steps I took were:
1. deleted the existing tabs addon
2. Re-selected the tabs from the SPPB addons
3. Created tab names (tab 1, tab 2, et al)
4. Saved
5. Cleared browser cache
6. Cleared Joomla cache
7. Re-opened browser to website and saw same problem
9. Went into temporary Tourettes (expletives flying)
(repeated the same steps for the accordion... including step 9 -- still nada)

Attachments (4)

  • blankaddonsection.JPG
    blankaddonsection.JPG 81 KB
  • choosing tabs.JPG
    choosing tabs.JPG 80 KB
  • creatingnewtabs.JPG
    creatingnewtabs.JPG 102 KB
  • tabssectionsaved.JPG
    tabssectionsaved.JPG 78.8 KB

Michael Weaver

More than a month ago #Permalink
My apologies for being the ID10T error of the day... but still no change - see screenshot progression history

The steps I took were:
1. deleted the existing tabs addon
2. Re-selected the tabs from the SPPB addons
3. Created tab names (tab 1, tab 2, et al)
4. Saved
5. Cleared browser cache
6. Cleared Joomla cache
7. Re-opened browser to website and saw same problem
9. Went into temporary Tourettes (expletives flying)
(repeated the same steps for the accordion... including step 9 -- still nada)

Attachments (3)

  • browsercachecleared.JPG
    browsercachecleared.JPG 65.7 KB
  • clearingjoomlacache.JPG
    clearingjoomlacache.JPG 80.2 KB
  • sameerror.JPG
    sameerror.JPG 72 KB

Michael Weaver

More than a month ago #Permalink
Here's what it is doing on the backend... the tab divs are there but none of the demo content that I imputed is visible....

Attachments (1)

  • code inspect.JPG
    code inspect.JPG 191 KB

Paul Frankowski - Staff

More than a month ago #Permalink
Can I get access to your site, to check those two addons. Yes, use Private Messages only.

Michael Weaver

More than a month ago #Permalink
Apparently... 5th time is a charm. I uninstalled SPPB, then reinstalled it. Cleaned out the cache and what wasn't working is now working. For future reference So that I am not the perpetual nudnik.. and pestering you or whoever happens to be the unlucky tech support individual that gets me as a customer... what would cause that and why would the 5th reinstall make a difference when nothing was done differently in the process? Helix cover booxes still is giving an error [repetable_item title="Set1" image1="images/2018/08/23/utdoor-1.jpg" image2="images/2018/09/04/0.jpg"][/repetable_item]

Paul Frankowski - Staff

More than a month ago #Permalink
Thanks for access. But I couldn't login.

Anyway...
Cover boxes

what is that ? We do not have such a addon in our collection. Never heard/seen.
So maybe it doesn't belong to us, and you have to contact with its developer.


There are no replies made for this post yet.
Be one of the first to reply to this post!

Leaderboard (30 days)

Sifat

Sifat

Total Accepted Answers: 112
Paul Frankowski

Paul Frankowski

Total Accepted Answers: 96
Toufiq

Toufiq

Total Accepted Answers: 89
FUTURECLIENT

FUTURECLIENT

Total Accepted Answers: 2
Kamruzzaman Alam

Kamruzzaman Alam

Total Accepted Answers: 2

115

Templates

295767

Community Users

Newsletter

Don’t miss any updates of our new templates and extensions and all the astonishing offers we bring for you.
We never spam

Joomla! ® name is used under a limited license from Open Source Matters in the United States and other countries. JoomShaper.com is not affiliated with or endorsed by Open Source Matters or the Joomla! Project.

Connect Us