Support Forums

Support Online : Mon - Fri / 10am - 6pm (GMT +6)

Your Time: Our Time:

SP Simple Portfolio issue

Featured Lock Resolved Issue
After moving a number of categories (to be sub-categories) under a particular category, the frontend of the website shows up with this:

" You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near ') ORDER BY id ASC' at line 3"

Please help advise/resolve, thanks.

9 Answers

Sifat - Staff

4 weeks ago #Permalink
Hi,
Finally i get the issue. You are selecting some category which doesn't include to any portfolio http://prntscr.com/oiwehv. Please publish portfolio item on that category and sub-category and then select that category or subcategory. It won't auto fetch all the items from the sub categories.

-Thanks

BIS Webteam

More than a month ago #Permalink
Screenshot attachment

Attachments (1)

  • mysqlerror.png
    mysqlerror.png 64.1 KB

Sifat - Staff

More than a month ago #Permalink
Hi,
Thanks for your query. I think something is wrong with your database. We faced this same issue earlier and the issue was inconsistency in the update. That means may be you've skipped some update. So, what you can do is to take a backup of your site in your localhost and uninstall and reinstall the latest sp-simple-portfolio there and check if that's causing the issue or not. Here you'll find the similar solution https://www.joomshaper.com/forums/critical-error-message-with-oneclip-template#reply-75648

Please let me know if it helps.

-Best Regards

BIS Webteam

More than a month ago #Permalink
Hi Sifat,
I have tried taking a backup of our site, uninstalling and reinstalling the latest sp-simple-portfolio but the error still remains. Please help to assist.


Hi,
Thanks for your query. I think something is wrong with your database. We faced this same issue earlier and the issue was inconsistency in the update. That means may be you've skipped some update. So, what you can do is to take a backup of your site in your localhost and uninstall and reinstall the latest sp-simple-portfolio there and check if that's causing the issue or not. Here you'll find the similar solution https://www.joomshaper.com/forums/critical-error-message-with-oneclip-template#reply-75648

Please let me know if it helps.

-Best Regards

Sifat - Staff

More than a month ago #Permalink
Hi,
Thanks for your reply. Please check this screencast https://files.fm/u/u9z92mrq
Hope this will help you.

-Best Regards

BIS Webteam

More than a month ago #Permalink
Hi Sifat,

Thanks for your replied.

I've followed the video steps:
1. Uninstalled SP Simple Portfolio extensions
2. Drop the SP Simple Portfolio tables
3. Installed SP Simple Portfolio

I've created the new categories, subcategories and items again and clear the browser cache but I'm still facing the same 1064 error: "You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near ') ORDER BY id ASC' at line 3".

Appreciate if you could help to assist, thank you.

Sifat - Staff

More than a month ago #Permalink
Thanks for your reply. Please goto this file location /templates/shaper_floox/html/
Then rename the two folder named mod_spsimpleportfolio and com_spsimpleportfolio
to xmod_spsimpleportfolio and xcom_spsimpleportfolio like this http://prntscr.com/oi94pn

If that doesn't solve the issue either then please PM me your super user access. I'll check.

click on my avatar to get that option

-Thanks
Hi Sifat,

I have tried to follow your instructions as seen here, https://prnt.sc/oitt5t.

That still doesn't solve the issue. I will PM you our super user access.

Kindly assist to resolve. Thank you.

Thanks for your reply. Please goto this file location /templates/shaper_floox/html/
Then rename the two folder named mod_spsimpleportfolio and com_spsimpleportfolio
to xmod_spsimpleportfolio and xcom_spsimpleportfolio like this http://prntscr.com/oi94pn

If that doesn't solve the issue either then please PM me your super user access. I'll check.

click on my avatar to get that option

-Thanks


There are no replies made for this post yet.
Be one of the first to reply to this post!

Leaderboard (30 days)

Paul Frankowski

Paul Frankowski

Total Accepted Answers: 133
Sifat

Sifat

Total Accepted Answers: 87
Toufiq

Toufiq

Total Accepted Answers: 52
Pavel

Pavel

Total Accepted Answers: 6
Sohan

Sohan

Total Accepted Answers: 5

114

Templates

293026

Community Users

Newsletter

Don’t miss any updates of our new templates and extensions and all the astonishing offers we bring for you.
We never spam

Joomla! ® name is used under a limited license from Open Source Matters in the United States and other countries. JoomShaper.com is not affiliated with or endorsed by Open Source Matters or the Joomla! Project.

Connect Us