Support Forums

Support Offline : Mon - Fri / 10am - 6pm (GMT +6)

Your Time: Our Time:

SP Weather error

Featured Lock Resolved Issue
I have setup an account for the API as per the instructions and saved it to the module
I have the module loaded onto an article via the {loadposition weather} in an article and get this error

MOD_SPWEATHER_ERROR_CANNOT_FIND_FORECAST_DATA Also make sure your location is current. Verify your location from here https://openweathermap.org/find

I have used the City Name Sydney, AU

I have verified my location and it does come up ok

18 Answers

Sifat - Staff

More than a month ago #Permalink
Hi,
Thanks for your query. I found it's working fine in my end. Please make sure your API is correct and working properly. http://prntscr.com/mqtfav

-Best Regards

Mark

More than a month ago #Permalink
The API key I copied and pasted and have double checked.

Is it related to joomla/ php
I'm running Joomla 3.8.7and php 7.0.33

Sifat - Staff

More than a month ago #Permalink
Please use the latest version of joomla and at least php version 7.1 and let me know if that solves the issue.

Mark

More than a month ago #Permalink
The site is busy at the moment so I don't want to upgrade that site but have tried the module on another site with the latest joomla 3.9.3 and php 7.2.15 same result

See the error at the bottom of this page
https://splatgraphics.com.au/paypal.html

Error
Can't forecast decode data. Also make sure your location is current. Verify your location from here https://openweathermap.org/find

I also tried their test url http://api.openweathermap.org/data/2.5/forecast?id=2147714&APPID=
with my key in the string and that did return the data

Sifat - Staff

More than a month ago #Permalink
Would you please check your PM? I've texted you.

Mark

More than a month ago #Permalink
That worked. So have I create the wrong API key or is not activated

Roger Kaufmann

More than a month ago #Permalink
Hi Sifat,

I'm having the exact same issue on my site (https://cineaulac.ch/index.php/horn/aktuelles-wetter-auf-dem-horn). The API is correct and the location is found on openweathermap.

Can you help, please? Thanks!

Sifat - Staff

More than a month ago #Permalink
That worked. So have I create the wrong API key or is not activated

I'm having the exact same issue


openweathermap api actually takes some time to approve your api and that's why initially your api isn't working. You need to wait a bit or contact to openweathermap's support to activate your api.

-Thanks

Carlos Jimenez

More than a month ago #Permalink
I have the same problem, it only works, when I disable the estimation of one or more days

http://www.agronten.cl

place: VICTORIA, CL

Roger Kaufmann

More than a month ago #Permalink
it only works, when I disable the estimation of one or more days


Weird ... yes, disabling the forecast shows today's weather no problem. @JoomShaper: are you sure it's not the module?

Thanks!

Sifat - Staff

More than a month ago #Permalink
Would you please check this screencast https://files.fm/u/zsgd5d5w

Roger Kaufmann

More than a month ago #Permalink
Would you please check this screencast https://files.fm/u/zsgd5d5w


Hi Sifat,

I'm not sure what you're trying to tell us with that screencast. If I turn the forecast off (i.e. disable) I get the current weather, but if I use any forecasting, I get the error.

I've contacted openweather.org and they're checking on their end.

Thanks,

Roger

Sifat - Staff

More than a month ago #Permalink
Would you guys please use this api and check if it's working or not
API: 554348026706259352d167e514b815a1

Carlos Jimenez

More than a month ago #Permalink
with your apikey it works. with another NO!

Roger Kaufmann

More than a month ago #Permalink
with your apikey it works. with another NO!


Agreed, it works fine with the API key above ... with my own it only works when the forecast is disabled. I've set. a new key, too, but this takes time to be active. Will report if that key works with the forecast.

Thanks!

Sifat - Staff

More than a month ago #Permalink
Actually i'm not sure but i think the API needs some time to activate. That's why may be other api's won't working.

Roger Kaufmann

More than a month ago #Permalink
Actually i'm not sure but i think the API needs some time to activate. That's why may be other api's won't working.


It does, but I've used both the "old" Api key (at least two months old) and the new one (about three days old) and neither can handle a forecast. Both are fine without the forecast, though. So I don't think it's an API key issue...

Thanks!

Sifat - Staff

More than a month ago #Permalink
Ok i'm informing our development team about that. That's what i can do for you.

-Thanks


There are no replies made for this post yet.
Be one of the first to reply to this post!

Leaderboard (30 days)

Sifat

Sifat

Total Accepted Answers: 132
Paul Frankowski

Paul Frankowski

Total Accepted Answers: 98
Toufiq

Toufiq

Total Accepted Answers: 26
Pavel

Pavel

Total Accepted Answers: 4
Al Mamun

Al Mamun

Total Accepted Answers: 3

113

Templates

289848

Community Users

Newsletter

Don’t miss any updates of our new templates and extensions and all the astonishing offers we bring for you.
We never spam

Joomla! ® name is used under a limited license from Open Source Matters in the United States and other countries. JoomShaper.com is not affiliated with or endorsed by Open Source Matters or the Joomla! Project.

Connect Us