Support Offline : Mon - Fri / 10am - 6pm (GMT +6)

Your Time: Our Time:

SP Weather - No day shown in Block view and FLAT style - List & Default view is OK

Featured Lock Resolved
Hi,

When using the new SP Weather module in Block mode and Flat design, no day is shown in the view, however it is shown in List view, is there anything I'm missing? I can't see any setting to show the day in either option.

When using Default styling, the day does show OK.

Screenshots attached :)

Thanks for any advice.

Chris

Attachments (2)

  • weather-no-day.jpg
    weather-no-day.jpg 16.5 KB
  • weather-list.jpg
    weather-list.jpg 25.9 KB

11 Answers

Sifat - Staff

More than a month ago #Permalink
Hi,
Please goto this file location /modules/mod_sp_weather/tmpl/flat.php
Then replace the attached file there and that'll solve the issue for flat style.

-Best Regards

Attachments (1)

  • flat.zip 2.9 KB

Sifat - Staff

More than a month ago #Permalink
Hi,
Thanks for your query. Please check the issue using protostar template. I found it's working fine here in my end. I'm using helix-ultimate here and the weather api is openWeatherMap here is the public api 554348026706259352d167e514b815a1

-Best Regards

Chris

More than a month ago #Permalink
Hi Sifat,

I see the same issue with the Protostar template - no day is showing, when using OpenWeatherMap as suggested.

The template is Helix Ultimate-based.

Chris

Sifat - Staff

More than a month ago #Permalink
Hi,
Thanks for your reply. Please check this screencast https://files.fm/u/r6rj8ynn

Chris

More than a month ago #Permalink
Hi Sifat,

I appreciate you may be able to get it to work, but I can't - even your demo of SP Weather shows no days on the flat layout (bottom-right/last one): SP WEATHER - FLAT BLOCK LAYOUT

http://demo.joomshaper.com/extensions/others/column3/sp-weather

All other layouts show days except this one. For me, the colourful layouts also give HTTPS warnings in Chrome, the Flat displays don't.

Chris

Sifat - Staff

More than a month ago #Permalink
Please choose the default layout and check again http://prntscr.com/o4b5i2
Hope this will work

Chris

More than a month ago #Permalink
I don't want to use the default layout, the styling suits better on this project as Flat, and using the default layout gives an SSL warning in Chrome, since the coloured images are loaded over HTTP, not HTTPS.

Chris

Chris

More than a month ago #Permalink
Hi,
Please goto this file location /modules/mod_sp_weather/tmpl/flat.php
Then replace the attached file there and that'll solve the issue for flat style.

-Best Regards


Will do, thanks :)

Chris

Chris

More than a month ago #Permalink
Hi,
Please goto this file location /modules/mod_sp_weather/tmpl/flat.php
Then replace the attached file there and that'll solve the issue for flat style.

-Best Regards


Worked perfectly :)

Thanks!

Chris

Sifat - Staff

More than a month ago #Permalink
You are always welcome :)


There are no replies made for this post yet.
Be one of the first to reply to this post!

Leaderboard (30 days)

Paul Frankowski

Paul Frankowski

Total Accepted Answers: 148
Sifat

Sifat

Total Accepted Answers: 91
Toufiq

Toufiq

Total Accepted Answers: 51
Kamruzzaman Alam

Kamruzzaman Alam

Total Accepted Answers: 2
RV

RAFFAELE VIOLA

Total Accepted Answers: 1

116

Templates

299004

Community Users

Newsletter

Don’t miss any updates of our new templates and extensions and all the astonishing offers we bring for you.
We never spam

Joomla! ® name is used under a limited license from Open Source Matters in the United States and other countries. JoomShaper.com is not affiliated with or endorsed by Open Source Matters or the Joomla! Project.

Connect Us