Support Offline : Mon - Fri / 10am - 6pm (GMT +6)

Your Time: Our Time:

Sticky header not working...

Featured Lock Resolved Issue
Hello, the sticky menu is not working in my instance. When viewing on desktop, the menu does not stay visible, and when on mobile, the mobile menu does not appear. I have verified that "Sticky menu" is enabled on the template settings. The canvas menu module is enabled. And I have not turned off the location within SP Page builder. So I'm at a loss on how to fix. Can I get some assistance please? I can PM the website development address. Thank you in advance. -Scott

18 Answers

Toufiq - Staff

More than a month ago #Permalink
HI,

Please remove this js code from main.js file
templates/shaper_politist/js/main.js

// fix conflicting with mootools
if (MooTools != undefined) {
var mHide = Element.prototype.hide;
Element.implement({
hide: function() {
if ($('[data-toggle="tooltip"]').attr('itemprop')) {
return this;
}
mHide.apply(this, arguments);
}
});
}


-Thanks

ScottCA

More than a month ago #Permalink
Hi Paul,
The 1st link didn't change anything when applied to my instance. The 2nd link, helped, but pushed all the social media icons to a stack on the left side, everything was off center, but the sticky menu did work. Thoughts? PS. I will PM the site address to you.

Paul Frankowski - Staff

More than a month ago #Permalink
As the first step please use this:

@media screen and (max-width: 767px) {
#sp-header {display:block;}
}

#sp-header, #sp-mobile-header {
position: fixed;
width: 100%;
}


Then I need access to admin to improve layout settings for mobile view.
Yes, use PM (hidden in my profile)

Attachments (1)

  • custom_css_field_helix3.png
    custom_css_field_helix3.png 9.9 KB

ScottCA

More than a month ago #Permalink
Thanks Paul. PM sent.

ScottCA

More than a month ago #Permalink
Hi Paul,
After applying the last settings, I now notice that the breadcrumb is not displaying correctly. It's higher, and almost getting chopped off. See the attached screenshot. Thanks.

Attachments (1)

  • breadcrumb_issue.png
    breadcrumb_issue.png 37.2 KB

Paul Frankowski - Staff

More than a month ago #Permalink
Header in mobile view fixed, almost all just by settings from Layout.

Paul Frankowski - Staff

More than a month ago #Permalink
Page title also have more top margin.
---
Breadcrumbs section not touched.

Attachments (1)

  • titles.jpg
    titles.jpg 45.8 KB

ScottCA

More than a month ago #Permalink
Thank you both for your help! It looks perfect now.

~Scott

giasqui

More than a month ago #Permalink
Hi!
I've the same issue with header menu. I've copy the code above on custom.css and header start work on smartphone but not well formatted, while header doesn't start work on tablet.
May you help me?
Thanks.

Toufiq - Staff

More than a month ago #Permalink
Hi!
I've the same issue with header menu. I've copy the code above on custom.css and header start work on smartphone but not well formatted, while header doesn't start work on tablet.
May you help me?
Thanks.


Hi, Please share your site url. Thanks

giasqui

More than a month ago #Permalink
Hi, Please share your site url. Thanks


http://www.biscegliesvolta.it/politist/

Toufiq - Staff

More than a month ago #Permalink
Hi, There has media query css and it display:none. Could you send me administrator access via pm? Thanks

giasqui

More than a month ago #Permalink
Hi, There has media query css and it display:none. Could you send me administrator access via pm? Thanks

Done!
Please share solution.
Lot of thanks!

Toufiq - Staff

More than a month ago #Permalink
Hi, There has media query css and it display:none. Could you send me administrator access via pm? Thanks

Done!
Please share solution.
Lot of thanks!


Hi, Please check now. Thanks

giasqui

More than a month ago #Permalink
Great! It works but there are some items not aligned. You can see it in the pics attached. May you please share the solution here?
Lot of thanks.

Attachments (1)

  • Capture.JPG
    Capture.JPG 55 KB

Toufiq - Staff

More than a month ago #Permalink
Great! It works but there are some items not aligned. You can see it in the pics attached. May you please share the solution here?
Lot of thanks.


Hi, I have open responsive.less file and find out the code sp-header{display :none}. Then i have commented out. Our template design wasn't the information. Please check our demo. Sorry to say that, customization support is not allowed.

-Thanks


There are no replies made for this post yet.
Be one of the first to reply to this post!

Leaderboard (30 days)

Paul Frankowski

Paul Frankowski

Total Accepted Answers: 119
Sifat

Sifat

Total Accepted Answers: 63
Toufiq

Toufiq

Total Accepted Answers: 60
Mehtaz Afsana

Mehtaz Afsana

Total Accepted Answers: 13
Rashida Rahman

Rashida Rahman

Total Accepted Answers: 11

118

Templates

302815

Community Users

Newsletter

Don’t miss any updates of our new templates and extensions and all the astonishing offers we bring for you.
We never spam

Joomla! ® name is used under a limited license from Open Source Matters in the United States and other countries. JoomShaper.com is not affiliated with or endorsed by Open Source Matters or the Joomla! Project.

Connect Us