We’re with you. JoomShaper is offering a 20% Discount on all plans due to the impact of COVID-19.

Support Offline : Mon - Fri / 10am - 6pm (GMT +6)

Your Time: Our Time:

SP Pagebuilder pro with Testimonial Pro issue!

Featured Lock Resolved Issue
Hi, please take a look at my website
Scroll all the way down, and look at the testimonial pro.
What is going on? I have made 3 items, and in between the slides there seems to be some empty space.
Do you know why this is? Can you help to solve this?

Regards, Peter

12 Answers

Toufiq - Staff

More than a month ago #Permalink
Hi,

Please check now your testimonial issue.

Added this javascript code inside main.js file


//fix carousel issue fr mootools
var carousel = jQuery('.carousel');
if(carousel){
window.addEvent('domready', function(){
if (typeof jQuery != 'undefined' && typeof MooTools != 'undefined' ) {
Element.implement({
slide: function(how, mode){
return this;
}
});
}
});
}


-Thanks

Toufiq - Staff

More than a month ago #Permalink
Hi,

Please follow the forum post solution.

https://www.joomshaper.com/forums/carousel-slides-not-working

-Thanks

Peter Spiegelenburg

More than a month ago #Permalink
Hi Toufiq,

thanks for your reply. But, it is not working.
I have also checked the site mentioned in the other post, also there it is not working.
I have created a little video in the attachment that shows the issue.

Please help me further on this.

Regards, Peter

Attachments (1)

  • testimonial.zip 807 KB

Toufiq - Staff

More than a month ago #Permalink
Hi,

Thanks for your reply. I didn't see this code. You didn't follow the above forum post URL.
https://www.glashartpurmerend.nl/templates/shaper_helix3/js/main.js


//fix carousel issue fr mootools
if (typeof jQuery != 'undefined' && typeof MooTools != 'undefined' ) {
(function($) {
$(document).ready(function(){
$('.sppb-carousel').each(function(index, element) {
$(this)[index].slide = null;
});
});
})(jQuery);
}


-Thanks

Peter Spiegelenburg

More than a month ago #Permalink
Hello Toufiq,

I have followed your advice: in the file
components/com_sppagebuilder/assets/js/sppagebuilder.js
i have changed the code you said (please see attachment.
But nothing has changed.
I will sent you the FTP-account. Maybe you can take al look?

Regards, Peter

Attachments (1)

  • 2017-07-18_10-42-48.jpg
    2017-07-18_10-42-48.jpg 57.1 KB

Toufiq - Staff

More than a month ago #Permalink
Hi, Thanks for your reply. Access doesn't work. Thanks

Peter Spiegelenburg

More than a month ago #Permalink
I have sent you again the account settings. Maybe I made a typo in the first. Do you get a login screen when you go to the server?

Toufiq - Staff

More than a month ago #Permalink
Hi,

When i trying to login in FTP it says and no directory found.

Status: Retrieving directory listing...

After some time it says this message:
Error: The data connection could not be established: ETIMEDOUT - Connection attempt timed out

-Thanks

Peter Spiegelenburg

More than a month ago #Permalink
Hi Toufiq,

I have installed a file manager tool.
Please check your PM.

Regards,
Peter

Peter Spiegelenburg

More than a month ago #Permalink
Hi,

Please check now your testimonial issue.

Added this javascript code inside main.js file


//fix carousel issue fr mootools
var carousel = jQuery('.carousel');
if(carousel){
window.addEvent('domready', function(){
if (typeof jQuery != 'undefined' && typeof MooTools != 'undefined' ) {
Element.implement({
slide: function(how, mode){
return this;
}
});
}
});
}


-Thanks


Hi Toufiq, YES! Now it is working fine. Thank You!

Regards, Peter

(p.s. Will I have to do this again, when a new version is being released?)

Toufiq - Staff

More than a month ago #Permalink
Hi,

Please check now your testimonial issue.

Added this javascript code inside main.js file


//fix carousel issue fr mootools
var carousel = jQuery('.carousel');
if(carousel){
window.addEvent('domready', function(){
if (typeof jQuery != 'undefined' && typeof MooTools != 'undefined' ) {
Element.implement({
slide: function(how, mode){
return this;
}
});
}
});
}


-Thanks


Hi Toufiq, YES! Now it is working fine. Thank You!

Regards, Peter

(p.s. Will I have to do this again, when a new version is being released?)


Hi, Thanks for your reply & you are most welcome. :)


There are no replies made for this post yet.
Be one of the first to reply to this post!

124

Templates

331316

Community Users

Newsletter

Don’t miss any updates of our new templates and extensions and all the astonishing offers we bring for you.
We never spam

Joomla! ® name is used under a limited license from Open Source Matters in the United States and other countries. JoomShaper.com is not affiliated with or endorsed by Open Source Matters or the Joomla! Project.

Connect Us