Support Forums

Support Offline : Mon - Fri / 10am - 6pm (GMT +6)

Your Time: Our Time:

The "close" button in the editing of articles of K2 via the frontend does not work

Featured Lock Resolved Bug
Hello

The "close" button in the editing of articles of K2 via the frontend does not work.

I've tried various configurations of JQuery K2 and did not work, including some found here on the Forum.

By clicking the "close" button simply nothing happens!

What is the solution?

I'm using the latest version of K2

8 Answers

Fabio Rogerio

More than a month ago #Permalink
Hey Alex,

I'm very happy!:D :D

After two intense days I finally got it, it was my God's blessing!


Solution:

Open the files:

templates\YOUR_THEME\html\com_k2\templates\default\itemform.php

components\com_k2\templates\default\itemform.php



Replace the line 49:

<a class="toolbar" href="#"> <span title="<?php echo JText::_('K2_CANCEL'); ?>" class="icon-32-cancel icon-cancel"></span> <?php echo JText::_('K2_CLOSE'); ?> </a>

By this:

<a class="toolbar" href="#" onclick="window.history.back(0); return false;"> <span title="<?php echo JText::_('K2_CANCEL'); ?>" class="icon-32-cancel"></span> <?php echo JText::_('K2_CLOSE'); ?> </a>


Anyway, thanks for your attention!

This solution may fit others.

God Bless you!

Alex Smirnov

More than a month ago #Permalink
Hi Fabio,

Is there any chance you have "Admin Tools" installed on your system?

Please PM me your Joomla super user credentials to have a look around your system.

Ta

Alex

Fabio Rogerio

More than a month ago #Permalink
Hi

I'm working with localhost, this site is not online.

Fabio Rogerio

More than a month ago #Permalink
I believe it's a JQuery Conflict problem.

I've read various suggestions found on the web, but none solved.

Already uninstalled several extensions, and nothing has changed.

Note: I'm using the Simple Image Gallery Pro.

Alex Smirnov

More than a month ago #Permalink
Check if you have any JavaScript blocking set in your browsers or try viewing your local site via different browser.

If doesn't help, try changing your local WAMP server. For example, switching to XAMPP if you are running your site on WAMP-server and visa versa.

Cheers.

Fabio Rogerio

More than a month ago #Permalink
Hi Alex, Not solved! :(

Alex Smirnov

More than a month ago #Permalink
Hi Fabio,

Apology for the delay due to the weekend.

I am pleased to see you sorted out your K2 issue. Many thanks for kindly providing the fix to our community.

Cheers,

Alex


There are no replies made for this post yet.
However, you are not allowed to reply to this post.

Leaderboard (30 days)

Sifat

Sifat

Total Accepted Answers: 122
Paul Frankowski

Paul Frankowski

Total Accepted Answers: 115
Toufiq

Toufiq

Total Accepted Answers: 62
Pavel

Pavel

Total Accepted Answers: 4
W

woonydanny

Total Accepted Answers: 2

100+

Templates

200,000+

Community Users

Newsletter

Don’t miss any updates of our new templates and extensions and all the astonishing offers we bring for you.
We never spam

Joomla! ® name is used under a limited license from Open Source Matters in the United States and other countries. JoomShaper.com is not affiliated with or endorsed by Open Source Matters or the Joomla! Project.

Connect Us