Support Forums

Support Offline : Mon - Fri / 10am - 6pm (GMT +6)

Your Time: Our Time:

Twitter Addon still not working in latest release?

Featured Lock Resolved Bug
Experiencing an issue with the Tweet addon, when added to a page it brings up the following error:

Fatal error: Cannot use object of type stdClass as array in /**pathtoserver**/components/com_sppagebuilder/addons/tweet/site.php on line 48


This seems to relate to the avatar so I just switched that off for now, however once I did that the slider is empty and it merely has a timestamp of 48 years ago! In addition when the "show username" is set to YES a similar error occurs.

I tested using another username (yours - joomshaper) but issue remained the same.

14 Answers

Toufiq - Staff

More than a month ago #Permalink
Hi,

I have checked twitter addon. Working fine from my end inside page builder page. But, it has problem in module & article of page builder. We will fix it next update.

http://js.shobkhanei.com/helix_v1.9/
http://prntscr.com/eowniy

-Thanks

Toufiq - Staff

More than a month ago #Permalink
Hi,

Please following the below instruction.

Download the attachment & replace this file below file location.

components/com_sppagebuilder/addons/tweet/

-Thanks

Attachments (1)

  • site.zip 2.2 KB

Simon Logan

More than a month ago #Permalink
Updated and new error reads:


Fatal error: Cannot use object of type stdClass as array in /*pathto*/components/com_sppagebuilder/addons/tweet/site.php on line 55


So the line in question has changed but the error is still the same, not sure if it's the same issue or not.

Also, although you said that the issue only occurred when using Joomla Article plugin or the SPPB module I don't believe this is the case - the example I'm talking about (the details for which I PM'd you when you asked for admin access though it doesn't look as if you've actually logged in using those details yet) is using a full PageBuilder page, not an article plugin or module.

So not sure if the bug is with PHP versions or something else but every time I've tried to use the module so far, regardless of where I've tried to use it, it has given me that same error and the latest fix supplied doesn't seem to get it working either. (BTW I did clear the cache first)

Toufiq - Staff

More than a month ago #Permalink
Hi,

Thanks for your reply. Please let me know your PHP version.

-Thanks

Simon Logan

More than a month ago #Permalink
5.6.30 on the site in question - you can confirm this if you login using the admin details i gave you last week and go to the System Information page.

Though as mentioned before the error isn't specific to this site, I've tried it on a couple of different sites now, so I don't think it's PHP related, I just raised that as a possibility.

Whatever the issue is, I think it would be more useful if you investigated on a site which is actually having the issue (details already PM'd to you) rather than testing in another environment. If you need anything else from me just let me know.

Toufiq - Staff

More than a month ago #Permalink
Hi,

Thanks for your reply. I can't check your site twitter addon. Becuase of that, your site main index.php override.

http://peterarnottgolf.com/

-Thanks

Simon Logan

More than a month ago #Permalink
Ah, right, we're using the Coming Soon plugin - to access the frontend go to http://peterarnottgolf.com/?schawing=1

Sorry about that.

Toufiq - Staff

More than a month ago #Permalink
Hi,

I have checked your twitter addon & its working fine.

http://prntscr.com/epvbmv

Please enable & check
http://prntscr.com/epvc3i

-Thanks

Simon Logan

More than a month ago #Permalink
Hi Toufiq

Apologies for the delayed response, have been tied up with other work.

Checked on this now and I can confirm that the module you have there DOES work but the Twitter addon which I'd installed on the page "Home" using SPPB and the Twitter addon still didn't work at first, same error as before. I then tried swapping over the consumer key/secret and access token key/secrets to use the one you'd put it and it did start working. I noticed that your access token had a set of numbers at the start which mine didn't.

So i'm wondering now if the issue was incorrect token values? I'll check if that is the case but even if so I would suggest seeing if your module can catch this error and spit out a more useful error message if possible?

Toufiq - Staff

More than a month ago #Permalink
Hi,

Thanks for your reply. I have checked again via enabling Twitter feed addon. But, working fine. No problem found. Besides, if your access token wrong, then it won't be displayed.

-Thanks

Simon Logan

More than a month ago #Permalink
That's bizarre, tried again today and you're right, it is working. I ran an update to 2.4.2 yesterday before checking this again and it was still the same, however could it have been caching related?

I do still note that it is only loading a single tweet from 12 days ago and if you check the SP Tweet module I'd taken to using instead that loads three other tweets which are more recent. Is that just because they are retweets?

In the end, no idea how it happened, might have been after the 2.4.2 upgrade but seems to finally be working now, thanks Toufiq.

Toufiq - Staff

More than a month ago #Permalink
Hi, Thanks for your mail. Yes we fixed it latest version. Thanks

Simon Logan

More than a month ago #Permalink
Ah, okay, so there was something which was fixed - I thought it must have been me doing something wrong but if it was a bug after all then that's good to know.

Toufiq - Staff

More than a month ago #Permalink
Hi, Thanks for your reply. Yes there was little bug. That we have fixed. Thanks


There are no replies made for this post yet.
However, you are not allowed to reply to this post.

Leaderboard (30 days)

Paul Frankowski

Paul Frankowski

Total Accepted Answers: 138
Toufiq

Toufiq

Total Accepted Answers: 61
Shibbir

Shibbir

Total Accepted Answers: 27
Rifat Wahid Alif

Rifat Wahid Alif

Total Accepted Answers: 5
Pavel

Pavel

Total Accepted Answers: 4

100+

Templates

200,000+

Community Users

Newsletter

Don’t miss any updates of our new templates and extensions and all the astonishing offers we bring for you.
We never spam