Support Forums

Support Offline : Mon - Fri / 10am - 6pm (GMT +6)

Your Time: Our Time:

Validation Errors with Rental template

Featured Lock Resolved Issue
Hello i am using rental template with SPPB 3.2.4. I had used the Quickstart package. The problem is that i have many errors with https://validator.w3.org.

My website adress is https://mesogiaki-diatrofi.gr.

The problems are:
1. CSS: margin: Parse Error. and CSS: padding: Parse Error.
2. Element style not allowed as child of element div in this context. (Suppressing further errors from this subtree.)
3. The itemprop attribute was specified, but the element is not a property of any item. (Those are related to the blog addon)
4. The main element must not appear as a descendant of the section element.
5. Bad value //http://fonts.googleapis.com/css?family=Noto Sans:100,100i,300,300i,400,400i,500,500i,700,700i,900,900i&subset=cyrillic-ext for attribute href on element link: Illegal character in query: space is not allowed.
6. A document must not include both a meta element with an http-equiv attribute whose value is content-type, and a meta element with a charset attribute.

Please help me fix those cause i need the site to be w3 compliant.

Thank you.

10 Answers

Paul Frankowski - Staff

More than a month ago #Permalink
Hi,
first, you have to update SP Page Builder to 3.3.7 at least.
I guess you didn't buy a subscription for an update.
It should fix some problems.
---
Please send me access, click to my avatar there is Private Message button

I am not sure if all issues can be fixed, but I will try to help you as much I can.

Paul Frankowski - Staff

More than a month ago #Permalink
Should be better now.
----
--
But I cannot edit template nor SPPB source code.
So it's all I can do by now.

Akis

More than a month ago #Permalink
Hello again and thank you. I manages to solve some on my own.
The CSS: margin: Parse Error. and CSS: padding: Parse Error. is due to leaving "0" without "px" after it.

For the problem with the itemprop in blog addon i have read here: https://www.joomshaper.com/forums/itemprop-use-and-errors-in-templates, but i cant exactly figure it out.

Lastly about the error: Element style not allowed as child of element div in this context. (Suppressing further errors from this subtree.
This error is due to inline css in addons.
Although i try to delete all inline css and move it in my custom.css there is a line i cant remove and this is: "box-shadow: 0 0 0 0 #fff;". It would be wise that, if no box shadow color is chosen in the addon, then no inline css should be created. Now even if i dont choose a color the "box-shadow: 0 0 0 0 #fff;" is created as inline css.

Thanks for your time.

Paul Frankowski - Staff

More than a month ago #Permalink
BTW
<meta http-equiv="content-type" content="text/html; charset=utf-8" />


it's not from the helix, so it may be from Joomla itself.
---

Good advice, validation is a process during site building, not at the end when it's very hard to find what has to be changed.

Paul Frankowski - Staff

More than a month ago #Permalink
The CSS: margin: Parse Error. and CSS: padding: Parse Error. is due to leaving "0" without "px" after it.


Check "Home" page, all addons, columns and row settings, and when you will see "0" put "0px" if this may help.
Remember about responsive options for padding and margin, search there.

Akis

More than a month ago #Permalink
Hello again, i have renewed my subscription because i need your help.
I have managed to solve some validation problems but there are two that remain.

1 . The main element must not appear as a descendant of the section element.
2. Element style not allowed as child of element div in this context.

Akis

More than a month ago #Permalink
I managed to solve No 1 by replacing "main" with "div" in the plugins/system/helixultimate/layouts/frontend/componentarea.php.

It seems to be ok, if you have a better option please advise.
And please tell me a solution for No2. Its an error about the inline css in pagebuilder.

Paul Frankowski - Staff

More than a month ago #Permalink
I don't have fix code for you, also because I am sure what you mean about
Element style not allowed as child of element div in this context.

Akis

More than a month ago #Permalink
Ok i figured out what is causing this issue. If i create a module through joomla extensions and i select module type "SP Page Builder " then it creates a style element "<style type="text/css">'. $addon_css .'</style>';" inside the div of the module. This is considered an error with the w3 validator.

See attached image. 1234.jpg

Please consider fixing this in an upcoming update and please fix the box shadow, vertical offset, horizontal offset, blur and spread to be able to take blank prices. Now if i dont select a color in box-shadow it gives me "#ffffff"everytime, and the same goes with vertical offset, i cant leave it blank, it just take "0" and generates inlice css this way.

Attachments (1)

  • 1234.jpg
    1234.jpg 54.3 KB


There are no replies made for this post yet.
Be one of the first to reply to this post!

Leaderboard (30 days)

Paul Frankowski

Paul Frankowski

Total Accepted Answers: 129
Sifat

Sifat

Total Accepted Answers: 81
Toufiq

Toufiq

Total Accepted Answers: 66
Pavel

Pavel

Total Accepted Answers: 6
Sohan

Sohan

Total Accepted Answers: 5

114

Templates

293324

Community Users

Newsletter

Don’t miss any updates of our new templates and extensions and all the astonishing offers we bring for you.
We never spam

Joomla! ® name is used under a limited license from Open Source Matters in the United States and other countries. JoomShaper.com is not affiliated with or endorsed by Open Source Matters or the Joomla! Project.

Connect Us

Cron Job Starts