We’re with you. JoomShaper is offering a 20% Discount on all plans due to the impact of COVID-19.

Support Online : Mon - Fri / 10am - 6pm (GMT +6)

Your Time: Our Time:

Video BG Not looping

Featured Lock Resolved Issue
I have the background video set to "loop" but it is not looping. My video is a local video. Not YouTube, Vimeo, etc. Ideas?

13 Answers

The solution is actually more simple;

Line 339 needs changing to - it literally needs only a space added between "'.$video_loop.''.$video_params.'":


$html .= '<video class="section-bg-video" autoplay muted playsinline '.$video_loop.' '.$video_params.''.($lazyload ? ' data-poster="'.$video_poster.'"' : ' poster="'.$video_poster.'"').'>';

Mehtaz Afsana Borsha - Staff

More than a month ago #Permalink
HI,
Please see the screenshot below:
https://prnt.sc/s7sum4
You have to choose any one of these
Thank you

lmw1

More than a month ago #Permalink
I already did that. I chose an mp4 on my server. The video does not loop even though I have it set to loop in the settings provided.

Mehtaz Afsana Borsha - Staff

More than a month ago #Permalink
But its ok in our end
https://prnt.sc/s7tr0u
Did you try the youtube video?
This loop option is available only for these two options
YouTube/Vimeo
Thank you

lmw1

More than a month ago #Permalink
Ah! Only YouTube and Vimeo. I see. No option to loop mp4's on our own server? At all?

Mehtaz Afsana Borsha - Staff

More than a month ago #Permalink
Sorry there is no feature like this :)

Mohammed Ahmed

More than a month ago #Permalink
Can you not add the attribute?

https://www.w3schools.com/tags/att_video_loop.asp

I use local mp4s too as youtube/vimeo load a tonne of extra resources that affect pagespeed.

Mohammed Ahmed

More than a month ago #Permalink
I'm not sure why this is marked as resolved.

The attribute that is rendered by SP Page Builder is wrong.

SP Page Builder renders the below:

<video class="section-bg-video" autoplay="" muted="" playsinline="" looploop="" poster="/poster.jpg"><source src="/video.mp4" type="video/mp4"></video>


The generated markup just needs to be fixed for stored MP4s from "looploop" to just "loop":

<video class="section-bg-video" autoplay="" muted="" playsinline="" loop="" poster="/poster.jpg"><source src="/video720.mp4" type="video/mp4"></video>


It's an obvious bug, which *did* work in older 3.6.x versions of SP Page Builder.

Mohammed Ahmed

More than a month ago #Permalink
If you want all videos to loop, quick edit required to this file:

/components/com_sppagebuilder/layouts/row/start.php


Change line 339 from:

$html .= '<video class="section-bg-video" autoplay muted playsinline '.$video_loop.''.$video_params.''.($lazyload ? ' data-poster="'.$video_poster.'"' : ' poster="'.$video_poster.'"').'>';


to:

$html .= '<video class="section-bg-video" autoplay muted playsinline loop '.$video_params.''.($lazyload ? ' data-poster="'.$video_poster.'"' : ' poster="'.$video_poster.'"').'>';


You'll find the local video loops forever (note this overrides your settings I think).

Mohammed Ahmed

More than a month ago #Permalink
@Al Mamun - asked me to mention him on this thread.

hussein amr

More than a month ago #Permalink
@Mohammed Ahmed thanks for the solution worked like a charm
تسلم
This problem still exists in the latest update.


There are no replies made for this post yet.
Be one of the first to reply to this post!

126

Templates

334145

Community Users

Newsletter

Don’t miss any updates of our new templates and extensions and all the astonishing offers we bring for you.
We never spam

Joomla! ® name is used under a limited license from Open Source Matters in the United States and other countries. JoomShaper.com is not affiliated with or endorsed by Open Source Matters or the Joomla! Project.

Connect Us