We’re with you. JoomShaper is offering a 20% Discount on all plans due to the impact of COVID-19.

Support Online : Mon - Fri / 10am - 6pm (GMT +6)

Your Time: Our Time:

Warning message - htmlspecialchars() expects parameter 1 to be string ...

Featured Lock Resolved Bug
I just set up a new page builder page with some text blocks.
But for each and every text block that I add, I get the following warning.
I do not have anything else on my side, just 4 text blocks.
Joomla version and all extensions, SPPage builder e.g. seem all to be up to date.


Warning: htmlspecialchars() expects parameter 1 to be string, object given in /opt/lampp/htdocs/joomla/components/com_sppagebuilder/parser/addon-parser.php on line 584

Warning: htmlspecialchars() expects parameter 1 to be string, object given in /opt/lampp/htdocs/joomla/components/com_sppagebuilder/parser/addon-parser.php on line 584

Warning: htmlspecialchars() expects parameter 1 to be string, object given in /opt/lampp/htdocs/joomla/components/com_sppagebuilder/parser/addon-parser.php on line 584

Warning: htmlspecialchars() expects parameter 1 to be string, object given in /opt/lampp/htdocs/joomla/components/com_sppagebuilder/parser/addon-parser.php on line 584

Warning: htmlspecialchars() expects parameter 1 to be string, object given in /opt/lampp/htdocs/joomla/components/com_sppagebuilder/parser/addon-parser.php on line 584

Warning: htmlspecialchars() expects parameter 1 to be string, object given in /opt/lampp/htdocs/joomla/components/com_sppagebuilder/parser/addon-parser.php on line 584

Warning: htmlspecialchars() expects parameter 1 to be string, array given in /opt/lampp/htdocs/joomla/components/com_sppagebuilder/parser/addon-parser.php on line 592

5 Answers

Paul Frankowski - Staff

More than a month ago #Permalink
Hi,
probably guilty is your template.

SP Page Builder Documentation > Faq (Problems & Solutions) > Warning message - htmlspecialchars()

foto_4133_2020.jpg

Attachments (1)

  • foto_4133_2020.jpg
    foto_4133_2020.jpg 263.7 KB

Paul Frankowski - Staff

More than a month ago #Permalink
You can make a simple test. Set Prostostar as a default template and check SPPB again.
If it would be OK, you know that the template is "broken".

Susanne

More than a month ago #Permalink
Great advice for checking and it worked or better to say it (the template) did not work.

Thanks!

Paul Frankowski - Staff

More than a month ago #Permalink
That's why we have FAQ section.
Now contact with template developer and ask him for fix/update.


There are no replies made for this post yet.
Be one of the first to reply to this post!

124

Templates

331646

Community Users

Newsletter

Don’t miss any updates of our new templates and extensions and all the astonishing offers we bring for you.
We never spam

Joomla! ® name is used under a limited license from Open Source Matters in the United States and other countries. JoomShaper.com is not affiliated with or endorsed by Open Source Matters or the Joomla! Project.

Connect Us