Helix 2.0.7 Causing Fatal Error with Akeeba Ticketing System with Template Overrides - Forum | JoomShaper
Staff replied Helix Framework

Helix 2.0.7 Causing Fatal Error with Akeeba Ticketing System with Template Overrides

Asked by Rickard19 4 years ago Last activity 4 years ago

Hello,

I'm using Joomla 4.1.0, PHP 7.4 and using Helix 2.0.7.

I'm using Akeeba Ticketing System and when I test Akeeba Ticketing System with Helix Ultimate 2.0.7. It is causing a fatal error because of a template override.

I already submitted a ticket to akeeba and they said that a tempate override was causing the error.

"

Thank you for the backup archive. You indeed have a template override, but it's not an obvious one.

Please take a look at the folder templates/shaper_helixultimate/html/layouts/joomla/form/field , you will see that there is a file called user.php . The whole "html" folder will in turn call several template overrides scattered around the site, in your case it will load the file plugins/system/helixultimate/overrides/layouts/joomla/form/field/user.php . As you can see in line 52 they're still using the old syntax to load the modal behavior, causing the fatal error.

Please get in touch with the or update your website template, that should fix the issue. "

The ticketing system works fine when it's being viewed and submitting when used by "Public". When I login as "Registered" I get a 403 Forbidden Error. When I login as "SuperUser" I am able to choose from the dropdown menu my category, but when I choose to create a new ticket. It creates a fatal error.

Thank you for helping to fix. If you need to replicate. I've provided login details in "hidden content"

8 replies

Toufiq Senior Staff

Hi there,

Thanks for contacting us. Sorry for the inconvenience. Will you please provide me the Joomla administrator access to check the issue? I will check & get back to you soon. 

-Thanks

Rickard19 Asked this

Hello Toufig,

The link and admin user/pass were included in the orignal post in the "Hidden Content" Section. I'll post again in "Hidden Content" in this post.

Thank you

Rickard19 Asked this

Hello Toufig,

The Link & an Admin User / Pass was in the "Hidden Content" Section in the first post. I'll post it again in this post.

Thank you

Toufiq Senior Staff

Please check now. Initially solved your problem using default Joomla user.php file. Thanks

Rickard19 Asked this

Hello Toufig,

Thank you, Can you please explain what you did to fix the problem in case I need to fix this in the future?

Did you just copy and replace a file somewhere?

Thank you

Toufiq Senior Staff

I have replaced the user.php file default Joomla file to override file Helix Ultimate

/layouts/joomla/form/field/user.php

Helix override file location

plugins/system/helixultimate/overrides/layouts/joomla/form/field/user.php

Davelia

Hello:

I installed Gourmand tamplate and Akeeba Ticket System (Core free version) and it fails when creating a ticket.

It happens too with Helix Ultimate 2.0.7 but not with Casiopeia (default Joomla 4 template).

Bug #1: the Helix system plugin loads even when that template is NOT active in the frontend.

Bug #2: that plugin is using HTMLHelper('behavior.modal') which was removed since Joomla 4.0.0–Beta1 released back in 2019.

Thank you and best regards

Toufiq Senior Staff

@Davelia provide me the FTP access & Joomla administrator access. Thanks

Log in to reply.