error .htaccess Update Concerning Setting the Content-Encoding Header - Forum | JoomShaper
Solved General

error .htaccess Update Concerning Setting the Content-Encoding Header

Asked by Evas 3 years ago Last activity 3 years ago

It is misterious thing as in my .htaccess file it is included new code.
Header set Content-Encoding gzip

I do not quite understand why I get this error.
Any advise available on it?

.htaccess Update Concerning Setting the Content-Encoding Header

Since version 4.2.9

Before 4.2.9 the default htaccess.txt file contained erroneous code for appending the "Content-Encoding" HTTP header. This could result in double encoding errors when Joomla is installed in a subdirectory and both this directory and its parent directory contain an .htaccess file with this code. You should manually apply the necessary changes to any existing .htaccess file, as this file can not be updated automatically.

The old code:

Header append Content-Encoding gzip

The new code:

Header set Content-Encoding gzip

Accepted answer

Marked as the solution
Paul Frankowski Senior Staff
3 years ago · edited

Hi Evas,

it's topic/question for forum.joomla.org - to be honest.

But yes, it was change in joomla htacces file becuase it was problem with double (from htaccess and global configuration) gzip compression that crashed loading theme styles. But in new Joomla 4.3.x it's already fixed as I remember from Joomla Team update changelog.

Evas Asked this

I managed just today to figure out that I need to register to Joomla.org forum.
Had hard time to register there but now I am in, and thank you for your explanation.

I hope soon I will understand what topics are related to joomshaper and what not.

1 more reply

Paul Frankowski Senior Staff

All topics related to:

  • Joomla Core = forum.joomla.org + books + youtube + fanpages (FB)
  • Joomla Extensions and Templates = product developer website
  • Joomshaper products = our forum, chat etc.
  • Other questions = chat.openAI ;]

Have a nice day, and yes, indeed sometimes even a CMS core code generate problems.

Log in to reply.