the currentDate variable is undefined in the blog's single post blog.php. The same problem in the blog_style_default_item_title.php layout on line 51, the latter is shown in the list of blog elements.
This error shows up in Joomla 4 with expired articles.
I hope it is solved in the next version