Possible Bug? Updating Helix Ultimate To 2.0.11 In A Multilingual Environment Resets All Language Site Template Styles - Question | JoomShaper

Possible Bug? Updating Helix Ultimate To 2.0.11 In A Multilingual Environment Resets All Language Site Template Styles

J

Joonchen

Helix Framework 3 months ago

Hi there,

I just updated shaper_helixultimate from v2.0.10 to v2.0.11 and realized that the update has resetted all my different language Site Template Styles. Meaning: if you run a multilingual website and update Helix Ultimate to v2.0.11 chances are that you need to reconfigure ALL the language "Template Options" from scratch:

System > Site Template Styles > "Name_of_the_Template_Style" > Template Options (in different languages)

If you have 3 languages installed, as my websites, you need to reconfigure all 3 Template Options again from zero. This can be painful if you don't have a backup. Fortunately I had a cron job running on a daily basis, so I could restore a recent backup. Yes, my fault, I should have done a manual backup, but I thought it might be only a minor update change.

This is what I did:

(Under Joomla 4.2.0, SP Page Builder Pro v3.8.8, Helix Ultimate Framework v2.0.10, Helix Ultimate v2.0.10)

  1. I updated "System - Helix Ultimate Framework" v2.0.10 to v2.0.11. Result: all OK.
  2. I updated "shaper_helixultimate" v2.0.10 to v2.0.11. Result: the 3 language Site Template Styles have been resetted to its default settings. Meaning: the logo, navigation bar, etc. were set to the default values.
  3. I replicated the error by restoring my production site with a recent backup/restore (Akeeba). Then I created a staging clone copy to a subfolder of another domain I have. In the staging copy I updated the Helix Ultimate following step 1 and step 2, and voilà, the errors show up as I mentioned above.

This error does NOT show up when you don't use a multilingual website. I have other websites with only 1 single language installed. Updating to Helix v2.0.11 there doesn't cause any issues. But it certainly does on my multilingual websites.

Any hint to keep the different language Template Options untouched?

Thanks!

0
11 Answers
J
Joonchen
Accepted Answer
3 months ago

Hello? Anyone?

0
J
Joonchen
Accepted Answer
3 months ago

Please, guys, 4 days and still waiting for a response...

0
Toufiq
Toufiq
Accepted Answer
Senior Staff 3 months ago

Hi there,

Thanks for contacting us. Sorry for the inconvenience. Do you have any backup copy of your website which is used Helix version v2.0.10? If yes, Please provide me a akeeba backup zip file.

-Thanks

0
J
Joonchen
Accepted Answer
3 months ago

Hi Toufiq,

Thanks for replying. Much appreciated. See zip file below.

Cheers.

0
Toufiq
Toufiq
Accepted Answer
Senior Staff 3 months ago

You just make an zip file from jpa file. Please unpack your jpa file then make it zip file. Thanks

0
J
Joonchen
Accepted Answer
2 months ago

Please find the backup in ZIP-format file below. This ZIP file was not done by myself but by Akeeba directly. I alrady updated the site to the new Joomla 4.2.1 but the ZIP file still contains the 4.2.0 version.

0
J
Joonchen
Accepted Answer
2 months ago

Hello, any news? Thanks.

0
Toufiq
Toufiq
Accepted Answer
Senior Staff 2 months ago

Sorry mate. No clue found. Please allow more time. Thanks

0
Toufiq
Toufiq
Accepted Answer
Senior Staff 2 months ago

Sorry for the late response.

What i have done

https://drive.google.com/file/d/16fpnLUTZ-nFDndrNQWSdn1orLtUn3Zox/view

Added Akeeba backup inside the hidden content

0
J
Joonchen
Accepted Answer
2 months ago

Thanks Toufiq, for your time and effort.

The only difference between your update method and mine is that you uploaded the updated file manually from your computer. I used the automatic Dashboard > System > Update > Extensions method. Looks like the automatic procedure mixed something up. I don't know.

Anyway, good to know that, from now on, I will deal with Helix updates following your way.

Thanks again.

0
Toufiq
Toufiq
Accepted Answer
Senior Staff 2 months ago

Before Update you should enable the SCSS compile from template settings.

0