Sppagebuilder Addons Are Not Installed With The Template - Question | JoomShaper

Sppagebuilder Addons Are Not Installed With The Template

AD

Albatroz Digital

Template 2 months ago

Hi!

I'm trying to update a website layout by installing a new template.

I'm using template Politicas.

I've installed Page Builder Pro and then installed the Template Politicas, but the sppagebuilder addons "Donation" and "Press and Events Layouts" are not installed, why?

Thanks

0
29 Answers
Toufiq
Toufiq
Accepted Answer
Senior Staff 2 months ago

Hi there,

Thanks for contacting us. Sorry for the inconvenience. Here is explanation of Template only, quickstart, secondary template.

Template only

You will get only the new layout of template with design. The template only doesn't have page builder (pages, extensions, demo content)

Quickstart

You will get as it is like as demo except images (Everything is included inside the quickstart)

Secondary template

The secondary template made only for page builder odience based. Page builder pages included inside this template

-Thanks

0
AD
Albatroz Digital
Accepted Answer
2 months ago

Hi,

Thanks for the explanation...

So, installing page builder and the template i will not get the full functionality the template has.

That shouldn't be the case because we expect to have the template with all the addons available.

And the file of template only has the folder sppagebuilder, but it's not installed.... so why is it there if it's not used by the template installation?

Thanks

0
Toufiq
Toufiq
Accepted Answer
Senior Staff 2 months ago

So, installing page builder and the template i will not get the full functionality the template has.

No. But you can install the quickstart pack inside the localhost then you can import the pages. After that you need to insert images manually

If you need full demo as like demo. Then you have to use the quickstart pack.

0
AD
Albatroz Digital
Accepted Answer
2 months ago

Hi,

I have done that. I have installed the quickstart and exported the page builder and the template definitions. Then i imported both to my site, but i don't have the special addons "Donation" and "Press and Events Layouts".

They are not installed when i install the template, and they show like this: press_event_layouts insted of Press and events Addon

I just want the Specific Addons to work, "Donation" and "Press and events Addon".

Thanks

0
Toufiq
Toufiq
Accepted Answer
Senior Staff 2 months ago

Can you share your site administrator access to check the issue?

0
AD
Albatroz Digital
Accepted Answer
2 months ago

Hi,

Ok, i will pass the access, but i would like to add that i have copied the folder sppagebuilder from the template of quickstart to the components folder "/components/com_sppagebuilder/addons" and it started to work, but without language and maybe other things missing.

Thanks

0
Toufiq
Toufiq
Accepted Answer
Senior Staff 2 months ago

I think if you follow the video guideline you will gain the success.

https://www.youtube.com/watch?v=WXFd4RJVofA&t=2s

-Thanks

0
AD
Albatroz Digital
Accepted Answer
2 months ago

Hi,

So, i have to do it manually.

Ok, I've done that.

I only see one problem with this... is that if update pagebuilder the language file will be overwritten and i will have to re-do that part.

But what i don't understand is that... I'm working with one template not two different templates. So why does the installation of the template doesn't install all the files in it? (example folders sppagebuilder and webfonts)

And why doesn't they work from the templates folder like they work from quickstart?

Has i'm working with the same template the language file is already there and with all the items to those addons. Why doesn't he read those?

It seems to me that there is some bug here.

As i can workaround this by copying the files by hand, you should correct this.

It should be possible to install the template with all the folders and files and then install the sppagebuilder and it should detect the folder sppagebuilder inside the template with the specific addons and add those to the list of available addons.

Thanks

0
Toufiq
Toufiq
Accepted Answer
Senior Staff 2 months ago

Hi there,

Thanks for your feedback. If you want to use the Politicas template addon then you have make default template of Politicas.

https://prnt.sc/11gl5o5

-Thanks

0
AD
Albatroz Digital
Accepted Answer
2 months ago

Hi,

I'm sorry, but you're not understanding the problem I'm referring to.

What i'm saying is that when i install the template the folders sppagebuilder and webfonts are not installed, so when using the component Page Builder Pro i don't have the addons "Donation" and "Press and events Addon". That seems to me a bug, or there is a way to install that make those addons available.

It seems to me that there may be more users that don't use the quickstart and would like to use the templates and this is not possible the way it's installing.

How do you make the quickstart? There is something special about the quickstart, because SP Page Builder will look for the addons in the template and use them, but installing the template and the SP Page Builder individually it doesn't work.

And it starts with the template that strangely doesn't copy the folders sppagebuilder and webfonts when it is installed.

note: I know how joomla works.

Thanks

0
Toufiq
Toufiq
Accepted Answer
Senior Staff 2 months ago

Please share a screencast video about your issue. I will check & get back to you soon. Thanks

0
AD
Albatroz Digital
Accepted Answer
1 month ago

Hi,

Sorry, i didn't had time yet to make a screencast.

0
Toufiq
Toufiq
Accepted Answer
Senior Staff 1 month ago

So, How can i know the about your exact issue? Thanks

0
AD
Albatroz Digital
Accepted Answer
1 month ago

Hi,

By installing joomla and then installing the template you can see that there are 2 folders that are not installed: "sppagebuilder" "webfonts"

These are specific folders of this template. I even don't have the same fonts available that the template uses. So it seems to me that the template is not fully installed.

After this you can install the SP Page Builder.

Then if you create a page in Page Builder there are 2 addons of the template, ("Donation" "Press and events") that you can't use, because those folders are not installed.

Even if i copy the 2 folders "sppagebuilder" and "webfonts" mannually the Page Builder can't recognize them.

I have to copy them to addons folder of the component Page Builder so i can use them. But even with this, the language is not applied, but it exists in the language file of the template.

On the Quickstart these 2 folders "sppagebuilder" and "webfonts" exist in the template and are used by the Page Builder.

0
Toufiq
Toufiq
Accepted Answer
Senior Staff 1 month ago

I have checked my domain and it works fine.

https://prnt.sc/12f70iw

0
AD
Albatroz Digital
Accepted Answer
1 month ago

Hi,

Thanks for showing me that.

Well... in your site i don't see de addon donation and i can't see the addon Press and events. https://snipboard.io/BqM37J.jpg

On my site i had to copy those folders mannualy do the Page Builder component to have those addons available, but that are not correctly detected. https://snipboard.io/qy3ilK.jpg

I'm talking about these 2 folders available on the template that are not installed: https://snipboard.io/nNQqJ6.jpg

Whitout these 2 folders i can't use those addons on Page Builder and create the Home page like it is in the Quickstart.

Even if i copy those 2 folders to the template they are not available in Page Builder. I have "to invent" and copy those addons to Page Builder component folder. I can use them like that but this is just a workaround not the correct solution.

Thanks

0
Toufiq
Toufiq
Accepted Answer
Senior Staff 1 month ago

Download the zip file and uzip the file below file location

sppagebuilder.zip

https://prnt.sc/12hcrpe

-Thanks

0
AD
Albatroz Digital
Accepted Answer
1 month ago

Hi!

I have used your file and uncompressed to the template forlder, but the problem remain... https://snipboard.io/bA93YW.jpg

This folder is the same that comes with the template and putting this folder on the template mannually doesn't work, as i told earlier in the other posts. Please, read my posts carefully and you will see that i already did that.

SP Page Builder doesn't read the addons that come with the template even if copied to corect location. Another problem is that the template has that folder but it doesn't install them when the template is installed.

You can confirm this with your demo site as i told you before.

Thanks

0
Toufiq
Toufiq
Accepted Answer
Senior Staff 1 month ago

Hi there, Please check my site and donation addon. Thanks

0
Pavel
Pavel
Accepted Answer
1 month ago

Hi Albatroz Digital.

It was always a mystery to me why Joomshaper does not provide all extensions that are part of the template in the form of installation packages, as other developers do. After all, the use of QuickStart is not a very good starting point to create a new site. Moreover, any addon can be interfered with the installation file, so that the user would have the ability to install it through the standard means of installing extensions. It would be very solid for the company, but for some reason they do not do this and it is perplexed.

However, I can give you a few tips for a better understanding of how to move the add-ons from the Quickstart to the clean template.

  1. Install the template
  2. Install SP PB
  3. Replace folder /components/com_sppagebuilder/addons with similar from QuickStart
  4. Replace Folder or add if not existed /templates/your_template/sppagebuilder from QuickStart
  5. Replace Folder /components/com_sppagebuilder/assets/webfonts from QuickStart
  6. Replace Folder or add if not existed /templates/your_template/webfonts from QuickStart
  7. Replace file /language/en-GB/en-GB.com_sppagebuilder.ini from QuickStart
  8. Replace file /language/en-GB/en-GB.mod_sppagebuilder.ini from QuickStart

Some explanations for folder /templates/your_template/sppagebuilder. In this folder there are overrides of existing addons, but not the main addons themselves. You can modify the code of any add-on, place in this folder and will replace the existing add-on without changing the default code.

0
AD
Albatroz Digital
Accepted Answer
1 month ago

Hi,

Thanks Pavel. But i did every step but it's not working.

Toufiq: I see that now you have the Donation and Press Events Addon, what did you do to install the addons? It weren't there before.

Thanks

0
Toufiq
Toufiq
Accepted Answer
Senior Staff 1 month ago

Follow this instructions

Download the zip file and uzip the file below file location

sppagebuilder.zip

https://prnt.sc/12hcrpe

-Thanks

0
AD
Albatroz Digital
Accepted Answer
1 month ago

I did that.

It doesn't work.

Thanks

0
Toufiq
Toufiq
Accepted Answer
Senior Staff 1 month ago

Did you choose your default which is installed recent? Can you give me FTP access & Joomla administrator access?

0
AD
Albatroz Digital
Accepted Answer
1 month ago

Hi,

No, i didn't...

Now i see, i need to install the template and make it default so page builder could read the addons folder "sppagebuilder" from the template, right? Ok, i see that making the template as default, page builder will recognize those addons.

Good, that's something. :)

The problem is that i can't work in the background creating a new layout with this new template and maintain the older template as default. I need to have the old template until i have the new layout finished.

But it's ok, now i understand how can i make this work.

But, now i ask... why isn't this folder copied when the template is installed? This is what created the whole problem and questions...

Thanks

0
Toufiq
Toufiq
Accepted Answer
Senior Staff 1 month ago

Now i see, i need to install the template and make it default so page builder could read the addons folder "sppagebuilder" from the template, right?

Yes

But, now i ask... why isn't this folder copied when the template is installed? This is what created the whole problem and questions...

If you wanna use the template addons then you need to set default template which have you installed latest.

You can check this video

https://www.youtube.com/watch?v=WXFd4RJVofA&t=1s

-Thanks

0
AD
Albatroz Digital
Accepted Answer
1 month ago

Hi

You didn's understand what i said.

These 2 addons are from the template installed, but the 2 folders are not installed with the template. https://snipboard.io/MpIeo5.jpg

Thanks

0
Toufiq
Toufiq
Accepted Answer
Senior Staff 1 month ago

I will inform our developer team. I hope they will fix it as soon as possible. Thanks

0
AD
Albatroz Digital
Accepted Answer
4 weeks ago

Thanks

0