Lot Of CSS Codes In View Page Source - Question | JoomShaper

Lot Of CSS Codes In View Page Source

Arti Graphic

Arti Graphic

SP Page Builder 4 weeks ago

Hello. I use Joomla 4.4 with SP 5.3 and Helix ultimate 2.18

When i open any page and click on " View Page Source" from chrome browser, I found lot of unused CSS codes, empty classes and it's repeated, i don't understand how to remove it or why it created on the page.

Have a look to the image to understand me Thanks

0
16 Answers
Aris Ntatsis
Aris Ntatsis
Accepted Answer
3 weeks ago #155376

Same issue here: https://www.joomshaper.com/forum/question/30537 No solution provided. Waiting. The code appears only if you use the SPPageBuilder module in a template position.

0
Arti Graphic
Arti Graphic
Accepted Answer
3 weeks ago #155377

Yes it's apper when i use module built with SPPB only

0
Arti Graphic
Arti Graphic
Accepted Answer
3 weeks ago #155378

i can't check the link, i get this error 500 - You are not authorized to see this question Sorry, we can't find the page that you're looking for.

0
Aris Ntatsis
Aris Ntatsis
Accepted Answer
3 weeks ago #155379

Sorry. It is a private post. Didn't see it before.

0
Paul Frankowski
Paul Frankowski
Accepted Answer
Senior Staff 4 weeks ago #154666

Hi,

To remove/move that, in SPPB Settings you have to enable Production mode.

More Details: https://www.joomshaper.com/documentation/sp-page-builder/settings#advanced

0
Arti Graphic
Arti Graphic
Accepted Answer
3 weeks ago #154907

Hi, Thank your for your answer, But i tried this option and did what you say but nothing change

0
Paul Frankowski
Paul Frankowski
Accepted Answer
Senior Staff 3 weeks ago #154909

What SPPB version you have?

Have you disabled Joomla Cache.

0
Arti Graphic
Arti Graphic
Accepted Answer
3 weeks ago #155366

Hello again, I use Joomla 4.4 with SP 5.3 and Helix ultimate 2.18. And i already disabled Joomla Cache.

0
Paul Frankowski
Paul Frankowski
Accepted Answer
Senior Staff 3 weeks ago #155367
  1. In that case it's very weird. But, of course, I do not exclude the possibility that it could be a bug in our code.

  2. Do you have that on each subpage (where SPPB Is used) or only few?

Can you on Monday share access to admin area, as Super User

0
Arti Graphic
Arti Graphic
Accepted Answer
2 weeks ago #155469

Hello, This is my info

0
Paul Frankowski
Paul Frankowski
Accepted Answer
Senior Staff 2 weeks ago #155477

I informed developer. Thx @Arti

0
Arti Graphic
Arti Graphic
Accepted Answer
2 weeks ago #155612

Thank you too, and waiting for support

0
Arti Graphic
Arti Graphic
Accepted Answer
2 weeks ago #155738

Hello, Any new news?

0
Paul Frankowski
Paul Frankowski
Accepted Answer
Senior Staff 2 weeks ago #155767

Yes, as I said before, I created a ticket for our developers, and there is good chance this will be fixed in the next 5.3.1 update (May).


I privately assume that from the beginning Production mode was intended only for pages, hence the lack of placement of styles from SPPB modules in the PageX.css file

0
Arti Graphic
Arti Graphic
Accepted Answer
2 weeks ago #155919

Sorry, You mean this will fix in the new update?

And what you mean with this ( I privately assume that from the beginning Production mode was intended only for pages, hence the lack of placement of styles from SPPB modules in the PageX.css file )

I can't understand you

0
Paul Frankowski
Paul Frankowski
Accepted Answer
Senior Staff 2 weeks ago #155922

Yes.

Tech speach. Just focus on 1.

0