Too much load embedding mp4-videos - Forum | JoomShaper
Solved SP Page Builder

Too much load embedding mp4-videos

Asked by Felix Pena-Sommer 5 years ago Last activity 5 years ago

Dear all,

I've built this page https://www.moerike-gymnasium.de/index.php/moerike-profil/bilingualer-zug with the SP Page Builder. There are several mp4 videos included for example in Tab-Modules.
Unfortunately the Page requires several seconds when loading. The analysis in the browser shows, that the mp4 videos included on the page, although not automatically started, requires per video approx. 4 MB
https://1drv.ms/u/s!ApP852Q0XLwohMETX78CpRXDIg5HVQ?e=e1bHBp
And this although I've added for each Video a Poster Image, that's actually really small.
Is there a possibility to reduce network load in such cases?

Best regards
Felix

Accepted answer

Marked as the solution
Toufiq Senior Staff

Glad to heard that your problem solved. Please close the forum post and don't forget to give an upvote. Thanks

15 more replies

Toufiq Senior Staff

Hi there,

Thanks for contacting us. Sorry for the inconvenience. Please capture a screencast video about the full scenario.

-Thanks

Felix Pena-Sommer Asked this

Hi Toufiq,
thanks for your answer. What do you mean with Screencast?
You can easily analyze the problem.

  1. Load the https://www.moerike-gymnasium.de/index.php/moerike-profil/bilingualer-zug This takes several seconds depending on your bandwith.
  2. I analyzed the network load with chrome and the load is basically caused by loading the mp4 videos, which are included within the Tab-Modules. Even if they are not visible.

I wonder if it's possible to avoid the pre-loading of the mp4-files, since they should only be loaded when the video is explicitely started. I thought that a poster image would solve the problem, but that was not the case.

Any idea how to solve the network load?

Best regards
Felix

Toufiq Senior Staff

You have used the HTTPS and the HTTPS blocked the resource loading properly. Please check the console error.

https://prnt.sc/z2qfqa

Felix Pena-Sommer Asked this

I checked the console and found also the error net::ERR_HTTP2_PROTOCOL_ERROR.
This error appears only with chrome, but only on the page that was build with the SP Page Builder.
Is there something I can change in order to avoid this error? Are the videos causing this problem?
However the loading problem is still there. Cleaning the cache before it takes more than 6-7 seconds to load the page.
Do you see any chance to reduce this starttime?
Best regards
Felix

Toufiq Senior Staff

Is it possible to create same page in my website to check the loading speed? Thanks

Felix Pena-Sommer Asked this

I tried to do it, but without success. The page is there, but the mp4 files are missing. I can't upload files larger than 8 MB. That's at least the post_max_size defined in php.ini.
So, how may I help you to reproduce the load issue?

Toufiq Senior Staff

Please upload now your video. Thanks

Felix Pena-Sommer Asked this

Still not possible to upload files (mp4) larger than 8 MB. post_max_size is still defined with 8M.

Toufiq Senior Staff

Please provide me the mp4 video files via google drive. I will download your video and I will check my end. Thanks

Felix Pena-Sommer Asked this

You can find all relevant mp4-Videos on Onedrive (s. PM).

Log in to reply.