Problem with php version - Forum | JoomShaper
Staff replied SP Page Builder

Problem with php version

Asked by Denis 5 years ago Last activity 5 years ago

Hello,
sp page builder does not suport php version 7.3 + .
joomla dos not provide security upgrade for php version under 7.3, so is possible update sp pagebuilder that works on php 7.3 or 7.4

9 replies

Paul Frankowski Senior Staff
5 years ago · edited

Hi,
SPPB Pro works perfect on PHP 7.3
Many many users here use it, also on PHP 7.4.
I use PHP 7.3 on 60 websites with SPPB installed.

Problem can be caused by your template, extra plugin or module.
Without details from you hard to give you any advice.

Paul Frankowski Senior Staff

joomla dos not provide security upgrade for php version....

to be honest, Joomla is not PHP developer. Joomla use PHP, as car use road.

Denis Asked this

I know that.

joomla dos not provide security upgrade for php version....

This is the message that is shown to me in the admin zone if I set PHP 7.2.
If I set php 7.4 then this message disappears, but I have a lot of error show in error log for SP page builder, and helix framework. Helix show error on minfy part, sp page builder show several error with some call function function css and some string........

I decided to set everything up to php 7.4 and install from scratch. For now, the helix framework works normally, but I haven't installed the sp page builder yet.

When I finish and if the problem will be active, I'll send you an error_log

Paul Frankowski Senior Staff
5 years ago · edited

PHP 7.3 is still valid & safe version, and all should work correct. You can wait with using PHP 7.4 few weeks in case of problems.

But in general, You didn't provide us any details about errors during using PHP 7.3.
So how do we know what's not working and how to help you. We need details + screenshots etc.

Denis Asked this

[18-Feb-2021 08:51:43 UTC] PHP Deprecated: Array and string offset access syntax with curly braces is deprecated in /public_html/components/com_sppagebuilder/helpers/css-parser.php on line 110

This has been shown today, otherwise there will be more error in error log..

Paul Frankowski Senior Staff
  1. Template name?

  2. What SPPB Pro version you have installed ?

Denis Asked this
  1. Template is custom made with helix. I use defoult helix template, but I change name of template.
  2. SPPB Version: 3.7.9

PHP version on cPanel 7.4, but I change now on: PHP 7.3 , and I think that error log is empty. There is no error on php 7.3.

I will check error log when I will be on dekstop computer.

Paul Frankowski Senior Staff

ad 1) Helix II, Helix3, Helix Ultimate. This same I could say to Microsoft support I have Windows, hello!!

This error appear on all pages or only selected?

Log in to reply.