Adding a custom icon set in SPPB version 5 breaks the library icon view - Forum | JoomShaper
Solved SP Page Builder

Adding a custom icon set in SPPB version 5 breaks the library icon view

Asked by Mr Zen 3 years ago Last activity 3 years ago

I've uploaded a custom icon set in SPPB version 5 using fontello. However when I click the replace icon in the editor I get the following error:

Unhandled Runtime Error
TypeError: Cannot read properties of undefined (reading 'viewBox')

I have to either remove or switching off the custom icons to restore functionality.

Accepted answer

Marked as the solution
Toufiq Senior Staff

Please check now. Thanks

2 more replies

Toufiq Senior Staff

Hi there,

I appreciate you reaching out. I sincerely apologize for this oversight. Will you please provide me the Joomla administrator access to check the issue? I will check & get back to you soon. 

-Thanks

Mr Zen Asked this

Please see the attached details. I have activated the custom font.

To replicate go to any page builder page choose/edit an Icon addON and try to replace an Icon.

Mr Zen Asked this

I can confirm that has been resolved. Thank you very much for looking into that and fixing so quickly.

Log in to reply.