Deprecated: Creation of dynamic property Helix3Feature - Forum | JoomShaper
Solved Templates

Deprecated: Creation of dynamic property Helix3Feature

Asked by 71Media 2 years ago Last activity 2 years ago

I just bought the latest version of the Shapper Soccer template (version 3). I installed it on our development site and I got some errors about deprecated creation of dynamic properties (Helix3).

So I also download the Helix3 extensions from here but that does not make any difference. Still the same errors.

I am on PHP 8.2 and Joomla version 4.4.1
Can you help me fix those errors?

Accepted answer

Marked as the solution
Paul Frankowski Senior Staff

OR

Quick solution:

Download Helix3 quickstart and from it take this folder:
templates/shaper_helix3/features

And using FTP tool overrides all files here:

templates/shaper_soccer/features

it should help for last 4 "Deprecated" messages.

6 more replies

Rashida Rahman Staff

Hi there!

Sorry for your experience.

Will you please check with PHP 8.0 to see if it helps? Kindly clear your Joomla and browser caches deeply, then let me know the outcome.

Best Regards

71Media Asked this

These errors only occur on php 8.2. Not on lower versions.

71Media Asked this
2 years ago · edited

Yes that did the trick. Thank you!

Now I only need a solution for the first error regarding the deprecated code in templates/shaper_soccer/index.php on line 22.

And the errors in the footer in the templates/shaper_soccer/html/layouts/chromes/sp_xhtml.php file

Can you also fix that?

Paul Frankowski Senior Staff
  1. I don't have offcial fix. Just hide showing errors in Global Configuration.
  2. About "sp_xhtml.php" take this file from Helix3 template as well. It should help.
71Media Asked this
  1. Just hidding the errors is not a fix for us. We just don't want php errors on our website. No offense but "you" wrote a piece of code, selling it to customers and have no fix for the depreciated code? I am sure you can do better than that.
  2. Yes that worked fine. Thank you.
Paul Frankowski Senior Staff

The problem is that NOT all templates are PHP 8.2 ready. And this is NOT a typical error, but "legacy" mode.

71Media Asked this

Ok but we can also live with an unoffcial fix.

Log in to reply.