Error disable Joomla 6.0.3 plg_behaviour_compat6 - Forum | JoomShaper
Staff replied Helix Framework

Error disable Joomla 6.0.3 plg_behaviour_compat6

Asked by ssnobben 6 months ago Last activity 5 months ago

Hi there is some issues with Joomla 6 and disable the plg_behaviour_compat6 ( Joomla 6.0.3, php 8.4.18) latest Helix Ultimate. Pls test, investigate and report back.

"Attempted to load class "Helper" from namespace "HelixUltimate\Framework\Platform".
Did you forget a "use" statement for another namespace?"

Report error crasched fontpage with Maximus report and debug on:

Symfony\Component\ErrorHandler\Error\ ClassNotFoundError
in /var/www/vhosts/site.com/httpdocs/templates/shaper_helixultimate/error.php (line 19)

use Joomla\CMS\Uri\Uri;
use Joomla\CMS\Language\Text;
$app = Factory::getApplication();
$doc = Factory::getDocument();
$template = Helper::loadTemplateData();
$params = $template->params;
$fontCSS = '';
function addGoogleFont($fonts)
{

require() in /var/www/vhosts/site.com/httpdocs/libraries/src/Document/HtmlDocument.php (line 734)
HtmlDocument->_loadTemplate() in /var/www/vhosts/site.com/httpdocs/libraries/src/Document/HtmlDocument.php (line 788)
HtmlDocument->_fetchTemplate() in /var/www/vhosts/site.com/httpdocs/libraries/src/Document/HtmlDocument.php (line 625)
HtmlDocument->parse() in /var/www/vhosts/site.com/httpdocs/libraries/src/Document/HtmlDocument.php (line 643)
HtmlDocument->render() in /var/www/vhosts/site.com/httpdocs/libraries/src/Document/ErrorDocument.php (line 139)
ErrorDocument->render() in /var/www/vhosts/site.com/httpdocs/libraries/src/Error/Renderer/HtmlRenderer.php (line 70)
HtmlRenderer->render() in /var/www/vhosts/site.com/httpdocs/libraries/src/Exception/ExceptionHandler.php (line 142)
ExceptionHandler::render() in /var/www/vhosts/site.com/httpdocs/libraries/src/Exception/ExceptionHandler.php (line 76)
ExceptionHandler::handleException() in /var/www/vhosts/site.com/httpdocs/libraries/src/Application/CMSApplication.php (line 350)
CMSApplication->execute() in /var/www/vhosts/site.com/httpdocs/includes/app.php (line 58)
require_once('/var/www/vhosts/site.com/httpdocs/includes/app.php') in /var/www/vhosts/site.com/httpdocs/index.php (line 51)
Error

Class "Joomla\CMS\Filesystem\File" not found

13 replies

Paul Frankowski Senior Staff
6 months ago · edited

Hi,

It should be fixed in next update, by now keep "Behaviour - Backward Compatibility 6" plugin enabled - as we informed in Helix documenation. If you disabled it by mistake, enable it back from Joomla Admin or DataBase Manager.

ssnobben Asked this

It should be fixed in next update

When is this update coming?

Paul Frankowski Senior Staff

Beta should be this month, you can wait.

ssnobben Asked this

Paul Frankowski
Senior Staff 2 weeks ago

220289

Beta should be this month, you can wait.

Still waiting.

Paul Frankowski Senior Staff

We got Beta1 for testing, but I am not sure if I can share with you. Ping me in next 2-3 days, then we can talk.

ssnobben Asked this

OK will wait for the relase then

thks

Paul Frankowski Senior Staff

Please wait for next week, I should get a beta2/rc1 that I can share here. During the weekend our dev team do not work, so next days.

ssnobben Asked this

Its been a long wait. :)

Chris Elliott

I am very confused.

Helix Ultimate 2.2.0 is showing as supporting Joomla 6.0.0 but when I try to upgrade a site from 5.4.4 to J 6.X, I have to disable the plg_behaviour_compat (not the plg_behaviour_compat6) I get a serious front and backend Error all related to Helix.

What could this be caused by?

ssnobben Asked this

I had this problem before too. I was a time consuming try and error and I got it to work. Now waiting for Helix Update and get some love from the devs here. Cheers!

Paul Frankowski Senior Staff

Chris,

not 2.2.0, but 2.2.4 (this is the last version!) - with compability plugin all works. I have several J6 sites with that. Right now I cannot share beta of 2.2.5, I hope in next days.

ssnobben Asked this

Ok great looking forward soon to the release.4

Thks.

Paul Frankowski Senior Staff

We have delay with new Helix code, becuase EasyStore update must be first tested & presented.

Current Helix works in J6.1, but ... you know..

Log in to reply.