What Is This Error In Pagespeed Insights Area Label? - Question | JoomShaper

What Is This Error In Pagespeed Insights Area Label?

Igors

Igors

SP Page Builder 1 week ago

I tested my page in page speed insights my webpage and found this error? Before i did not notice such error. This is feature addon with icon. Can you fix this?

[aria-] attributes do not match their roles Each ARIA role supports a specific subset of `aria-attributes. Mismatching these invalidates thearia-*` attributes.

<div class="sppb-icon"><span class="sppb-icon-container" aria-label="Auto kravu pārvadājumi"><i class="icon icon-truck111" aria-hidden="true"></i></span></div>

0
9 Answers
Toufiq
Toufiq
Accepted Answer
Senior Staff 3 days ago

Hi there,

Thanks for contacting us. Sorry for the inconvenience. Developer team said that, we will improve it future update.

-Thanks

0
Igors
Igors
Accepted Answer
3 days ago

Hi Toufiq thanks. I got page speed insights 99 and there is only 3 errors left. This with area atribute. Second is with ofcanvas burger icon and logo. I was never so close to solve all Page speed problems. Both other are related to template. Please add logo image size in html output.

and here is last one with offcanvas icon:

[id] attributes on active, focusable elements are not unique All focusable elements must have a unique id to ensure that they're visible to assistive technologies. Learn more.

Please see pdf with my pagespeed test

failiem.lv/down.php?i=864gz2unv
0
Toufiq
Toufiq
Accepted Answer
Senior Staff 3 days ago

Your page speed is very fine. If you give me the administrator URL then i will go to check the off-canvas issue. Thanks

0
Igors
Igors
Accepted Answer
3 days ago

HI Toufiq it would be great if you help solve this. Logo problem i solved publishing logo module and disabling in template area problem i can solve converting feature to html module and if offcanvas is solved we have no one error :) i never sow so good result.

access is in hedden content

0
Igors
Igors
Accepted Answer
2 days ago

HI Toufiq. I managed to get rid off all errors except offcanvas isue. I replaced featured and faq addons with html. Could you plese help?

To get this result i use jch optimize and cloudflare together. There in lright corner is button clean cf cache and it with api clears cloudflare cache.

0
Toufiq
Toufiq
Accepted Answer
Senior Staff 1 day ago

Please check now your off-canvas issue. Thanks

0
Igors
Igors
Accepted Answer
22 hours ago

Hi friend the problem is there. nothing changed. how i understand this is happening only in this domain, I checked others and there is not such isue. Realy do not understand how to solve this

0
Igors
Igors
Accepted Answer
22 hours ago

How i understand there is two similar divs. I tried to remove them from html code and it works fine just with one . I only do not understand why there is two similar divs?

0
Igors
Igors
Accepted Answer
21 hours ago

I removed code in headers\style-1\header.php <!-- if offcanvas position right --> and now everything is ok but this is not right solution. After update it will be there again.

0