Object Of Class StdClass Could Not Be Converted To String - Question | JoomShaper

Object Of Class StdClass Could Not Be Converted To String

R

Richard

SP Page Builder 1 month ago

I am adding an Image to a section, nothing too much at all but the image addon is causing this error message.

this is the process i am using: https://support.gingerweb.co.uk/eDuKBjgL

I can add any other addon into this position and it works fine but with the image addon after saving it from the default i get this error only on this page.

Console says: The resource from “https://www.domain.co.uk/404” was blocked due to MIME type (“text/html”) mismatch (X-Content-Type-Options: nosniff)

if i "hide" the addon it all works fine again

what could be causing this please?

0
10 Answers
Rashida Rahman
Rashida Rahman
Accepted Answer
Support Agent 1 month ago #157516

Hi there!

Thanks for reaching out to us and sharing your admin access. I will check and get back to you.

The administrative URL is taking time to load.

Best Regards

0
R
Richard
Accepted Answer
1 month ago #157743

Has it loaded yet?!

0
Rashida Rahman
Rashida Rahman
Accepted Answer
Support Agent 1 month ago #157750

Hi Richard,

Sorry for the unwanted delay. Yes I could login with VPN.

The template you are using is not from us, and the image addon is overrided there. So I just renamed the site.php file of that overrided addon. This enables the default image addon fron SP Page Builder to load. Thus problem solved.

https://share.cleanshot.com/jSXgqzFd

Editing file "/templates/jb_growth/sppagebuilder/addons/image/site.php" in template "jb_growth".

Please check that image addon, I have changed the demo image to a rndom one from your images, and it works fine.

https://share.cleanshot.com/WVz1VWD4

If you want to use the overrided image addon from your template then kindly ask your template provider about it. They are supposed to help you there, by correcting the code.

Best Regards

0
R
Richard
Accepted Answer
1 month ago #158762

Thanks for the explanation, i dont really fully understand why it is happening though! i am encountering errors more and more, what is causing this to happen?

https://support.gingerweb.co.uk/6quoYkG7

It works fine until i change anything at all in the addon?

I have tried putting a joomla module of a carousel in the same place and this gives me a different error:

array_merge(): Argument #2 must be of type array, null given

Any advice gratefully received. thanks

0
R
Richard
Accepted Answer
1 month ago #159144

Little nudge, can you look at this asap please?

0
Rashida Rahman
Rashida Rahman
Accepted Answer
Support Agent 1 month ago #159231

Hi!

Sorry for the delayed response.

I have done the same with your image carrousal addon overrided file. Please check now.

Best Regards

0
R
Richard
Accepted Answer
1 month ago #159235

Yes brilliant many thanks - which one would i need to change to make the addon Joomla Module work as that doies the same thing?

0
Rashida Rahman
Rashida Rahman
Accepted Answer
Support Agent 1 month ago #159278

You are always welcome.

You have mentioned a different error for module. It seems related to PHP version.

Would you please redirect me where you have this error?

Best Regards

0
R
Richard
Accepted Answer
1 month ago #159280

Yes of course, so on the same page i have tried to add a Joomla module addon. this throws a different error:

array_merge(): Argument #2 must be of type array, null given

and the page doesnt work - at the moment the module is live so you can see the issue

many thanks for your help with this

0
R
Richard
Accepted Answer
1 month ago #159507

I need to work on the site so have "hidden" the Section and clearly marked it. Basically if it is enabled then i get the above error on this page so hopefully you can rename something and fix this too? thanks

0