Error after upgrading PageBuilder from v3.8.5 to v3.8.6 - Forum | JoomShaper
Solved SP Page Builder

Error after upgrading PageBuilder from v3.8.5 to v3.8.6

Asked by Jeff Honeyager 4 years ago Last activity 4 years ago

The home page is a pagebuilder page.

Working fine with version 3.8.5

After upgrading to version 3.8.6

The home page threw out this error:

strpos(): Argument #1 ($haystack) must be of type string, stdClass given

I re-installed 3.8.5 and it is working fine - again.

????????

Accepted answer

Marked as the solution
Ofi Khan Staff

You are welcome. But I actually did not find the issue. I took a backup and tried on my localhost. Checked your system information. Then I have updated SP Page Builder on the localhost. There it worked fine. Then I have updated on your site.

4 more replies

Ofi Khan Staff

Hello Jeff Honeyager

Apology for the inconvenience. Please share your administrator access here to check the issue. Use the Hidden Content box to share the credentials. Make sure that you have a full site backup with you before sharing.

Best regards

Jeff Honeyager Asked this

The page that caused the error is titled:
Home - Marios

Note:

  1. when v3.8.6 was installed, other pages worked but not "Home - Marios"
  2. right now the site is using v3.8.5
Ofi Khan Staff

I have updated SP Page Builder. Please check your site now.

Jeff Honeyager Asked this

Thank you!

Can you tell me what happened, so I don't have to bother you again if the problem appears on another site?

Thanks.

Log in to reply.