Error after updating to php 8.1 - Forum | JoomShaper
Solved General

Error after updating to php 8.1

Asked by Ulrike Anton 3 years ago Last activity 3 years ago

Hello,
I just upgraded my php from 7.4. to 8.1. Most of my website works fine, however, when I switch languages I get the error "Unsupported operand types: string + int"

I use the latest Joomla 4 version and the Helix 3 template.

I found a similar post here: https://www.joomshaper.com/forum/question/17144?order=newest
It seems that the template needs an upgrade, right?

When can this be expected? - php 7.4 is not supported anymore...

Thank you!

Accepted answer

Marked as the solution
Ofi Khan Staff

icons_group addon site.php file has this PHP error. I have overridden the file. The new file is in this location: templates/shaper_helix3/sppagebuilder/addons/icons_group/site.php I have modified 2/3 lines.

19 more replies

Ofi Khan Staff

Hello Christoph

Which template are you using? Not all our templates are ready for PHP 8 yet. Please follow this blog to know more.

Best regards

Ulrike Anton Asked this

Thanks for the answer. as mentioned above, I am using Helix 3 template.
Will it be compatible with php 8/8.1 in the future?

Thanks!

Ofi Khan Staff

Helix3 3.03 is compatible with PHP 8.0. Please check the template version and downgrade PHP version to 8.0. Then check the warning message.

Ulrike Anton Asked this

Thanks.

I have downgraded to 8.0 now and the problem remains. When I switch languages, I get the error "Unsupported operand types: string + int"

Joomla and Helix-template are up to date.

I did´t have the problem with my old php version 7.4.

Please see hidden content for the URL to see for yourself. Thanks!

Ulrike Anton Asked this

Can anyone please help me with the technical issue descriobed in my previous post? - Thanks!

Ofi Khan Staff

Apology for the inconvenience. Please share your administrator access here to check the issue. Use the Hidden Content box to share the credentials. Make sure that you have a full site backup with you before sharing.

Ulrike Anton Asked this

Hello, please find the credentials in the hidden content box!
Thank you.

Ulrike Anton Asked this

Hello, I provided the credentials 5 days ago, is there any support at the moment? - The problem is urgent. Thanks.

Ofi Khan Staff

Apology for the delay. Please update to the latest Helix3 template and then check your issue.

Ulrike Anton Asked this

As I already pointed out twice (!), HELIX template and also plugin is up to date, and also Joomla is up-to-date.
Please use the login credentials (see above!) to see the problem. The whole english verison of the site isn´t working. Thanks.

Log in to reply.