Syntax error, unexpected token "\" - Forum | JoomShaper
Solved Templates

Syntax error, unexpected token "\"

Asked by Marco Spina 3 years ago Last activity 3 years ago

Hello there,
since some time my site is unreachable, the error shown is 'Syntax error, unexpected token "\"'.

Can you please help?

Thanks.
BR

Marco

P. S.: template is Helix Ultimate 2.0.12
P. P. S.: fixed by downgrading PHP from 8.0 to 7.4

Accepted answer

Marked as the solution
Ofi Khan Staff

Hello Marco Spina

Apology for the inconvenience. Please share your administrator access here to check the issue. Use the Hidden Content box to share the credentials. Make sure that you have a full site backup with you before sharing.

Best regards

6 more replies

Marco Spina Asked this

Hi Ofi,
actually, I found out that the problem was due to the php server's version (8.0); downgrading it to 7.4 solved the issue, but of course this is only a temporary solution, since php 7.4 is going end-of-life. Is it available already a Helix Ultimate php 8 compatible? If not, when it will be available?

Thanks.

Marco

Ofi Khan Staff

Helix Ultimate is PHP 8 compatible. It should not happen on PHP 8.

Marco Spina Asked this

Well, it isn't.
I confirm that after switching to PHP 8 the site stops working. I downloaded and reinstalled once again the template from your site without success.
Please find in the hidden content your admin credentials.
Thanks.

Ofi Khan Staff

You have an older SP Page Builder version which is not compatible with PHP 8. Please update SP Page Builder. Hopefully, your issue will be solved.

Marco Spina Asked this

Yes, upgrading SP Page Builder made the job.
Thanks!

BR

Marco

Ofi Khan Staff

You are welcome 😊

I have a humble request. It would be very kind of you if you can manage some moment to give us feedback on 

  1. Joomla Extension Directory
  2. TrustPilot

This will inspire us to improve.

Log in to reply.