SP LMS installation - Forum | JoomShaper
Solved Extensions

SP LMS installation

Asked by Alvas 2 years ago Last activity 2 years ago

I buyed just now a personal plan and downloaded new version of extensions to update my site J3.10.12.
I installed SP Page Builder Pro vers. 3.8.10 without errors, but when I downloaded and installed SP LMS vers. 4.0.8 my site is disappeared at all: in home page frontend and also in administrator page!!!
How can I fix it?
Tx

Accepted answer

Marked as the solution
Paul Frankowski Senior Staff

This Custom CSS should help:

@media screen and (min-width: 820px) {
article.item .content-wrap
{padding-left: 80px;}
}
Alvas Asked this

Thanks a lot!!! Fixed it!

20 more replies

Ofi Khan Staff

Hello al

Please share a screenshot of your issue to understand it better. Take a screenshot and share via any platform. For example: Lightshot or Imgur

Best regards

Paul Frankowski Senior Staff
2 years ago · edited

If you have access to J! admin:

error_reporting_debug.jpg

If not, edit configuration.php file (FTP) and edit those lines, to set this values:

public $debug = true;

public $error_reporting = 'maximum';

Then you should see more about Error details.

BTW

  1. I hope you know that Joomla 3.10 support ended in Sep 2023?
  2. What PHP version you have set?
Alvas Asked this
2 years ago · edited

Ok, this is the error that appear:
Fatal error: Cannot declare class plgSystemSplmsupdater, because the name is already in use in /web/htdocs/www.uni3.it/home/j4/plugins/system/splmsupdater/splmsupdater.php on line 0

I have J3.10.12 installed and the pre-upgrade analysis lists many row of probably incompatibility, also after I upgraded SP Page Builder Pro vers. 3.8.10, Template Educon, SP Simple Portfolio vers. 2.07. There are many plugin with warning!! I can't attach the screenshot in this text area :-( (Ther isn't the button to attach!).

  1. Yes, I know that Joomla 3.10 support ended in 2023 and it's for this reason I'd upgrade at J4!
  2. Now (in J3.10, before upgrade) PHP version is 7.4

How can I fix it?
Tx in advance

Alvas Asked this

Can I have support of you? Tx

Paul Frankowski Senior Staff
2 years ago · edited

By now disable plugin SP LMS Updater from Extensions Manager.


If your J! Admin do not work use FTP and:

  1. rename folder: plugins/system/splmsupdater/
  2. then disable plugin SP LMS Updater from J! Admin.
Alvas Asked this

Perfect!!! I regained access to Front & Administrative pages!!!
But now, how can I proceed to upgrade at J4???
If I launch the Joomla upgrade, I see the summary that you can see here: https://drive.google.com/drive/folders/1M2POQ3zNJK0lRweEVV5GJMYRyR8j8S-j?usp=sharing.
But I already updated SP Page Builder, SP LMS, Educon Template and other extensions, but into pre-update check to J4 seems like is not enough for proceed. How con I fix it?
Tx a lot

Paul Frankowski Senior Staff

Ignore and upgrade. BACKUP first.


SPPB 3.8.10 can be used ONLY inside Joomla 4.4x, not J5.

Alvas Asked this

Ok, thanks a lot!
Your suggestions are OK: I updated to J4.4.2.
How can I proceed now?
Can I rename at orignal name the folder: plugins/system/splmsupdater/ and can I enable SP LMS Updater from J! Admin?
If I'd update at J5, can I update SP Page Builder Pro vers.5 AFTER update Joomla?
Thanks

Paul Frankowski Senior Staff

yes, you can try.

Alvas Asked this

Can I have support of you? Tx

Log in to reply.