After migrating error.php: 500 An error occurred while updating the database - Forum | JoomShaper
Solved Helix Framework

After migrating error.php: 500 An error occurred while updating the database

Asked by Kathleen Grafe 2 years ago Last activity 2 years ago

Hallo,

after migrating from Joomla 3 to Joomla 5.1.4 with Shaper-helixulitmate 2.1.1 the following error occurs in error.php: 500 An error occurred while updating the database.
What could be the reason?

  • Linux cs509.fc-server.net 5.10.0-32-amd64 #1 SMP Debian 5.10.223-1 (2024-08-10) x86_64
  • DB: 10.11.9-MariaDB-deb11
  • PHP Version 8.2.20
  • Joomla! 5.1.4 Stable [ Kudumisha ] 27-August-2024 16:00 GMT

Thank you

Kathleen

Accepted answer

Marked as the solution
Atick Eashrak Shuvo Staff

Hi Kathleen,

If the solution worked and your issue is resolved, I would be grateful if you could mark the issue as solved. Additionally, if you have a moment, your feedback in a review would be much appreciated!

You can leave a review here:

JED Review
Trustpilot Review

Thank you for your time and support!

Best regards

6 more replies

Atick Eashrak Shuvo Staff

Hello Kathleen,

Thank you for reaching out.

I apologize for the inconvenience. To assist you better, could you please provide a screenshot of the error message? This will help us understand the issue more clearly and provide a more accurate solution.

Looking forward to your response.

Best regard

Atick Eashrak Shuvo Staff

Hello Kathleen,

Thank you for bringing this to my attention, and I apologize for any inconvenience this may have caused. To assist you more effectively, could you please share your Joomla administrator access(in the hidden content)? Before providing the access, I strongly recommend taking a backup of your site to ensure all your data is secure.

This will allow me to investigate the issue thoroughly and work on a prompt solution.

I appreciate your cooperation and will follow up with you as quickly as possible.

Best regards

Kathleen Grafe Asked this

Of course, gladly. Thank you.

Atick Eashrak Shuvo Staff

Hi Kathleen,

Thank you for reaching out. To resolve the error you are encountering during the database update, please run the following SQL query on your database:
ALTER TABLE `yourdatabaseprefix_redirect_links` CHANGE `new_url` `new_url` VARCHAR(2048) CHARACTER SET utf8mb4 COLLATE utf8mb4_unicode_ci NULL;

Make sure to replace yourdatabaseprefix with the actual prefix used in your project database. This should solve the issue.

Best regards

Kathleen Grafe Asked this

This worked wonderfully. Thank you and all the best.

Log in to reply.