Error after Quikstart Install - Forum | JoomShaper
Solved Templates

Error after Quikstart Install

Asked by Patricia Lee 5 years ago Last activity 5 years ago

Hi there

With the Edulif Quickstart installed (no errors during process) I get this error when logged in as Super User and trying to go to Menu > Compnentns > SP LMS

Call to undefined function cal_days_in_month()

Subsequently .. it doesn't open the Component. I did try to install that separately but this doesn't change that it won't open afterwards.

Template otherwise works fine. Any help is appreciated.

Accepted answer

Marked as the solution
Ofi Khan Staff

You are welcome

There is an accept answer option bottom-left of every comment.

4 more replies

Patricia Lee Asked this
5 years ago · edited

To add to this ticket

I created a fresh install at a different URL and set up just core joomla - then installed SP-LMS

As with the quickstart, I get the below error when tying to access the program through the Joomla Menu.

Call to undefined function cal_days_in_month()

I also tried diffeent PHP versions from 7.1 to 7.4x and the error is consistant.

Looking forward to some help on this.

Patricia Lee Asked this

So after a lot of Googling I find that the issue is the sofware requires the following PHP Extension to be added to the server.

php73-php-calendar

Might be an idea to add this to the requirements list.. I'd have spotted that instantly.

Ofi Khan Staff

Hello Patricia Lee

You got it right. You need to compile PHP with --enable-calendar extension. Please check the Documentation If you are not sure how to compile, then check this Documentation

Best regards

Patricia Lee Asked this

Hi and thank you,

I already did the legwork - thankyou very much though. I appreciate your help.

I wasn't sure how to close this ticket but it's by all means resolved.

Log in to reply.