Hi, please i need help to solve an error when i try to installlate the sp page builder in my website, y currently update from joomla 3 to joomla 5 and now, when i try to upload the sp page builder again, the system says: JInstaller: :Instalar: Error SQL Duplicate column name 'catid'
Error JInstaller: :Instalar: Error SQL Duplicate column name 'catid'
Accepted answer
Marked as the solutionHello,
To resolve the issue, Please, follow these steps (Before doing this, Please, taking your database backup first.):
Navigated to cPanel -> phpMyAdmin.
Select the relevant database.
Executed the following SQL operation:
ALTER TABLE `yourDatabaseTablePrefix_sppagebuilder` DROP COLUMN `catid`
Here add your database table prefix in here yourDatabaseTablePrefix, You will found it in your Root Joomla folder -> configuration.php
After this sql operation, Please, Try to reinstall SP Page Builder Pro. Then clear your joomla cache.
Thank you.
Best regards,
ALTER TABLE yourDatabaseTablePrefix_sppagebuilder DROP COLUMN catid
it is not the only error that could appear.
if you try from version 4->5 more many tables can give error.
in this case copy the table name from the joomla installation error page, and the column that generates error and substitute in the string above as SQL command.
I solved this way