error after updating from joomla 4 to joomla 5 ::$position is deprecated - Forum | JoomShaper
Solved Templates

error after updating from joomla 4 to joomla 5 ::$position is deprecated

Asked by Miguel 1 year ago Last activity 1 year ago

Hi, how are you?
I´m getting this error after updating from joomla 4 to joomla 5:

Deprecated: Creation of dynamic property HelixUltimateFeatureLogo::$position is deprecated in /templates/babycare/features/logo.php on line 23
Deprecated: Creation of dynamic property HelixUltimateFeatureMenu::$position is deprecated in /templates/babycare/features/menu.php on line 26

I´m using Baby care template (version 2.0.1), System - Helix Ultimate Framework (2.1.3), joomla 5.3.3, php 8.2.29.
The error is shown under the menu and not in every page. What is it?
Thanks!

Accepted answer

Marked as the solution
Paul Frankowski Senior Staff

Hola Miguel.

It's easy to solve alone:

Take that same file from Helix Ultimate template folder and override here: /templates/babycare/features/menu.php

Just download Helix Ultimate template, unzip and find: features/menu.php

2 more replies

Ziaul Kabir Staff

Hello,

Thanks for reaching out to us. Could you please share temporary administrator access to your Joomla backend? You can provide the credentials securely in the hidden content section. Also, please take a full backup of your site before we make any changes.

Once I have access, I’ll investigate further and see what’s causing the issue. Let me know once you’ve shared the details!

Best regards,

Miguel Asked this

Hi, I added the credentials in the hidden content!
thanks!

Ziaul Kabir Staff

Could you please re-check your site url, Currently not loaded on my end.

Thanks

Miguel Asked this

Hi! Could you tell me your IP so we add you to the whitelist?
Thanks!

Ziaul Kabir Staff

Here is my public ip: 119.148.4.217

Thanks

Miguel Asked this

Your IP is already whitelisted! Could you please try again?
Thanks!

Ziaul Kabir Staff

Please, check now. Your issues is resolved.
I have define a variable in both menu.php and logo.php in this path: /templates/babycare/features/

Thanks

Miguel Asked this

Thank you very much!

Ziaul Kabir Staff

It’s great to hear that your issue has been resolved.
If everything is working fine now, please mark the question as complete by accepting any of our answers.

Thank you!

Log in to reply.