Helix Ultimate 2.13 : "Error: undefined" cant save template - Forum | JoomShaper
Staff replied Helix Framework

Helix Ultimate 2.13 : "Error: undefined" cant save template

Asked by Rijeesh 1 year ago Last activity 1 year ago

am stuck, i am not able to save helix ultimate tempalte after joomla upgrade , what is this issue?

Joomla 5.3.3
PHP Version 8.2.27

4 replies

Rashida Rahman Staff
1 year ago · edited

Hi there!

Sorry for your experience.

Would you please give me your admin access to check the issue for you?

In the meantime, you may try the following steps:

  1. Disable ModSecurity on your hosting server.
  2. Ensure the correct file permissions are set for the template folder.

These actions should help resolve the issue you’re facing.

Best regards,

Rijeesh Asked this
1 year ago · edited

Hi Paul thanks,
below solutions didn't solved

  • template folder and files permissions are at 755

  • added these lines in .htaccess
    <IfModule mod_security.c>
    SecFilterEngine Off
    SecFilterScanPOST Off
    </IfModule>

  • am not using Akeeba Tools Pro

could you sugest any other solutions?

when i enabled error reporting to maximum i get below warnings

Deprecated: Creation of dynamic property HelixUltimateFeatureSocial::$position is deprecated in /home/u375800327/domains/......./templates/jb_interrio/features/social.php on line 36

Deprecated: Creation of dynamic property HelixUltimateFeatureSocial::$load_pos is deprecated in /home/u375800327/domains/......./jb_interrio/features/social.php on line 37

Deprecated: Creation of dynamic property HelixUltimateFeatureContact::$position is deprecated in /home/u375800327/domains/......./jb_interrio/features/contact.php on line 36

Deprecated: Creation of dynamic property HelixUltimateFeatureContact::$load_pos is deprecated in /home/u375800327/domains/......./jb_interrio/features/contact.php on line 37

Deprecated: Creation of dynamic property HelixUltimateFeatureLogo::$position is deprecated in /home/u375800327/domains/......./jb_interrio/features/logo.php on line 41

Deprecated: Creation of dynamic property HelixUltimateFeatureLogo::$load_pos is deprecated in /home/u375800327/domains/......./jb_interrio/features/logo.php on line 42

and more like this

Paul Frankowski Senior Staff
1 year ago · edited

Template jb_interrio does not belongs to JoomShaper, so I have to ask you to contact with Template developer. Here we support only JoomShaper templates. Support Policy 8.8. And our help ends here.
Evidence:
info_3269_2025.gif


About error messages:

Deprecated: Creation of dynamic property (...) /jb_interrio/features/contact.php , logo.php, social.php.

Is caused by PHP 8 version and older code used by template itself. Probably you set PHP 8.4 or PHP 8.3, that is too new for template version that you have right now. You need a new template version! Maybe consider using one of ours.

Log in to reply.