Categories list: Error 0 Class "ApplicationHelper" not found - Forum | JoomShaper
Solved Templates

Categories list: Error 0 Class "ApplicationHelper" not found

Asked by gemmajoom 9 months ago Last activity 9 months ago

The error appears when clicking on the menu item List of all categories in an item category tree.
With the cassiopea template the problem doesn't exist.

I can't provide links to my local site.

Joomla! 5.4.1
PHP 8.3.28
Template Themis 2.0.2

Accepted answer

Marked as the solution
Paul Frankowski Senior Staff

I don't know to be honest. But check by disabling all addons in SPPB module, and then enable one by one, to check how it will work.

gemmajoom Asked this

disabling SPPB modules, I just discovered that if I open them in the backend the same error appears:

An error has occurred. 0 Failed opening required 'C:\wamp64\www\mysite/administrator/components/com_sppagebuilder/builder/classes/base.php' (include_path='.;C:\php\pear')

https://files.fm/u/6attf774g7

4 more replies

Paul Frankowski Senior Staff

Hi,

but you have problem in admin area in Menu Manager? Or on front-end ?

gemmajoom Asked this

Front-end

Paul Frankowski Senior Staff
9 months ago · edited

But error seems to be from SPPB not template itself.

  1. Are you using SPPB on that view? If yes, please disable SPPB Module and recheck.
  2. List of all categories in your example is a menu item? Example below

info_3638_2025.jpg

I tested the same menu item on my site and was OK.

gemmajoom Asked this

I thought the problem was with the template because it works fine with Cassiopeia.

Menu Item Type:
Articles >> List All Categories in an Article Category Tree

Actually, disabling the SPPB modules that appear on that page makes the error disappear.
Why?

gemmajoom Asked this

disabling SPPB modules, I just discovered that if I open them in the backend the same error appears:

An error has occurred.
0 Failed opening required 'C:\wamp64\www\mysite/administrator/components/com_sppagebuilder/builder/classes/base.php' (include_path='.;C:\php\pear')

https://files.fm/u/6attf774g7

Paul Frankowski Senior Staff

Until you're on WAMP I cannot help more. It can be problem with Server settings, becuase I can still open and edit SPPB modules, like others webmasters.

Log in to reply.