Joomshaper 6.3.2 update crashed my site - Forum | JoomShaper
Staff replied SP Page Builder

Joomshaper 6.3.2 update crashed my site

Asked by Tim Snellings 5 months ago Last activity 5 months ago

I just updated my website with Joomshaper 6.3.2 and the install crashed my site. I'm getting this error: An error has occurred. 0 Class "BuilderAutoload" not found

My website is https://www.swanacal.com/ and you can see the 500 error.

I can't do anything in the Admin area of the website. Any ideas how to fix this and get my site back to working again? Please help, Thanks, Tim

3 replies

Paul Frankowski Senior Staff

Hi Tim,

  1. Use Hosting Support - ask them to recover site from backup (morning, yesterday)
  2. After, using Akeeba Backup make website backup
  3. Create test subdomain , test.swanacal.com
  4. Recover site from backup
  5. Enable showing Errors : Maxium and Debug mode in Global Configuration
  6. Share access (test) - we can play on that site update component without stress
Tim Snellings Asked this

FYI, here's what I did to recover my site:

1: Disable the plugin from the file system

Since Joomla admin was broken, I used my FTP program.

Then, I went to :

/plugins/system/sppagebuilder/

And did this:

Rename the folder: sppagebuilder → sppagebuilder_disabled

Then I tried to reinstall the newest version and it worked to recover my site. The issue seems to have been a corrupted installation process. All is well again...Thanks, Tim

Paul Frankowski Senior Staff

Probably during first update Joomla was not able to override with new files that folder and system crashed.

I had the same with different extension as well.


mark topic as solved.

Log in to reply.