SP Pagebuilder admin interface gives error: can't access property "data", e.response is undefined - Forum | JoomShaper
Staff replied SP Page Builder

SP Pagebuilder admin interface gives error: can't access property "data", e.response is undefined

Asked by Riku Lahteenmaki 1 month ago Last activity 1 month ago

After logging on to admin in Joomla 5, SP Pagebuilder (v6.8) gives error:

can't access property "data", e.response is undefined

This happens, when SP Pagebuilder admin interface is opened the first time during an admin session. After that the interface opens normally, when tried another time.

In the previous version of SP, the same happened, but the user was also logged out from the backend. The next time after logging on again, the SP interface was working normally.

5 replies

Ziaul Kabir Staff

Hello,

Thanks for reaching out to us. Could you please share temporary administrator access to your Joomla backend? You can provide the credentials securely in the hidden content section. Also, please take a full backup of your site before we make any changes.

Once I have access, I’ll investigate further and see what’s causing the issue. Let me know once you’ve shared the details!

Best regards,

Riku Lahteenmaki Asked this

Hi Ziaul,

I cannot give admin access to the site, because there is sensitive information.

Ziaul Kabir Staff

Then, please try reinstalling the latest version and clearing both your browser cache and Joomla cache.

Let me know the update.

Thanks!

Riku Lahteenmaki Asked this

The same error message shows despite reinstalling SP and clearing caches.

When exiting the admin page (with errors), I am logged out of Joomla. With the next login, the SP admin interface opens without errors.

Ziaul Kabir Staff

It’s great to hear that your issue has been resolved.
If everything is working fine now, please mark the question as complete by accepting any of our answers.

Thank you!

Log in to reply.