0 Array_replace(): Argument #1 ($array) Must Be Of Type Array, String Given - Question | JoomShaper

0 Array_replace(): Argument #1 ($array) Must Be Of Type Array, String Given

C

Chuck

Template 5 months ago

I am using the quickstart of HOPE. I spoke with Rashida in chat. I downgraded my php version to 7.4 but not sure how to change MYSQL to 5.5 in my phpmyadmin. I recieve the subject error when beginning to change menu items. I was using firefox to work in, but then error came up and changed to brave. Looked good until I started trying to change items. Error back. I am unsure how to proceed now. Assistance appreciated. Now, after rebooting computer and starting up again I can login and when login to use SP Pageb. FE editor I see the error again. This is in Chrome.

0
7 Answers
‏‏‎ ‎J‏‏‎‎e‏‎‏‏‎‎n‏‏‎‎s‏‏‎
‏‏‎ ‎J‏‏‎‎e‏‎‏‏‎‎n‏‏‎‎s‏‏‎
Accepted Answer
5 months ago

Hey Chuck,

please create a account with the following email adress. "[email protected]"
When i received the notification by joomla, that the account is created.
I will check and get back to you asap.

best regards Jens

0
Ofi Khan
Ofi Khan
Accepted Answer
Support Agent 5 months ago

Hello Chuck

This is a PHP 8 issue. PHP 7.4 should solve this. Please try it again with PHP 7.4.

Best regards

0
C
Chuck
Accepted Answer
5 months ago

I did change the php to 7.4 and got frontend editing to work, but now when I go to open a page in any browser I keep getting and error DNS_PROBE_FINISHED_NXDOMAIN which changed to ERR_TOO_MANY_REDIRECTS. I chatted with hosting tech, and said to contact you as there is some strange code loop causing this. I cleared caches on computer, and all browsers, but issue is an ongoing one. The backend works fine. Can't open a page, but can with frontend editor. Strange. I have never seen this issue in 15 years. I appreciate any help on this matter.

0
‏‏‎ ‎J‏‏‎‎e‏‎‏‏‎‎n‏‏‎‎s‏‏‎
‏‏‎ ‎J‏‏‎‎e‏‎‏‏‎‎n‏‏‎‎s‏‏‎
Accepted Answer
5 months ago

Hello @Chuck,
I am not a member of the support team, but I will try to help you.

Do you still need help?
I saw you are now using Helix Ultimate when i visited your page.

If yes, read bellow:

With the following bugfix for J4 and PHP8 from january, you can switch back to PHP8.
Hope is a template based on Helix3 and has the same problems as the helix3-template itself.

Issue: https://github.com/JoomShaper/Helix3/issues/111
Bugfix: https://github.com/JoomShaper/Helix3/pull/112/commits/079bb8f33d3c39b1c39ebc1d0bdb5f32da3e1a72

After you have applied the bugfix and switched back to PHP8, let me please know, if there are still issues.
If you don't want to change the file "helix3.php" yourself, I can also provide you with a patched file.

In addition to this, do not use a login-module or you will face a other problem.
Here the override of the login module has an error.

Issue: https://github.com/JoomShaper/Helix3/issues/113
possible bugfixes:

If you are also thinking about the usage of the joomla 4 API, you need to update the helix3.php again.
API-Doc: https://docs.joomla.org/J4.x:Joomla_Core_APIs#Get_Single_Article Issue: https://github.com/JoomShaper/Helix3/issues/114

I hope that I could help you with it already once basically.

I wish you a nice day.

0
C
Chuck
Accepted Answer
5 months ago

Hey Jens, Thank you for any assistance! My frustrations are running high. I have three subdomains working through all of the issues. I had all kinds of issues with login! Couldn't get to frontend editor. I did check the fixes, but not sure how to implement them. I looked through the overrides and no idea how to remove SP login. Still learning about overrides. So I changed back to php 8.0 I am still getting a 404 on any page I try to open from SP PageB in regular view or SP FE editor. I'd like to give you some credentials if you wouldn't mind. I really don't want to redo website again. Get back to me please.

Best wishes, Chuck P.

0
AC
Anthony Cowburn
Accepted Answer
2 days ago

Don't suppose there were any fixes?

0
‏‏‎ ‎J‏‏‎‎e‏‎‏‏‎‎n‏‏‎‎s‏‏‎
‏‏‎ ‎J‏‏‎‎e‏‎‏‏‎‎n‏‏‎‎s‏‏‎
Accepted Answer
1 day ago

@Anthony Cowburn
I had already helped chuck outside of joomshaper forum "email" after he provied me an administration account.
What problem are you having exactly, possibly an open post here on the forum?

One of the Problems was the htaccess file, which was not renamed. "404 error messages"
The other problem was within the helix3.php which I have then corrected.
PHP 8 compatibility and api calls

0