Major Site Crash After U/g Of SPPB To Version 5.3.2 - Question | JoomShaper

Major Site Crash After U/g Of SPPB To Version 5.3.2

CE

Chris Elliott

SP Page Builder 1 month ago

Was running SPPB 5.2.5 and ran the update to 5.3.2. This failed to install and resulted in a broken front and back end

I placed the entire broken site in a sub folder and restored from the backup so at least the site is running now but back on SPPB 5.2.5.

The broken version is still accessible for you to look into, see hidden details for logins.

The error seen is:

+++ 0 Failed opening required '/home/accountname/public_html/broken/components/com_sppagebuilder/builder/classes/base.php' (include_path='.:/opt/cpanel/ea-php83/root/usr/share/pear')

Pls advise as I would hate to have this occur on other sites.

0
7 Answers
Toufiq
Toufiq
Accepted Answer
Senior Staff 1 month ago #158857

Hi there,

Thank you for reaching out, and I apologize for any inconvenience caused by this oversight. Can you provide me FTP access to check the issue?

Best regards,

Toufiqur Rahman (Team Lead, Support)

0
CE
Chris Elliott
Accepted Answer
1 month ago #158858

See hidden details.

0
Toufiq
Toufiq
Accepted Answer
Senior Staff 1 month ago #158862

Please check & let me know. Thank you

0
CE
Chris Elliott
Accepted Answer
1 month ago #158864

Seems fine now. Please can you let me know if this was an error on my part or if you made changes that need to be appied in a new release of SPPB5?

Thx

0
Toufiq
Toufiq
Accepted Answer
Senior Staff 1 month ago #158886

Some files were not installed previously. I uploaded the missing files via FTP and fixed the database from the Joomla control panel. After that, I reinstalled the Page Builder. Everything is now resolved. Thank you.

0
CE
Chris Elliott
Accepted Answer
1 month ago #158888

Thanks Toufiq,

What are the chnaces this will happen again? I'm a little woriied to u/g a couple of other sites AND upgrading a handful of SPPB 3 sites to SPPB5!

Cab you advise if anything will be lost in the transition or if I need to do any prep work (oyther than a backup)?

0
Toufiq
Toufiq
Accepted Answer
Senior Staff 1 month ago #158889

Before update anything, you should keep a backup & before update you should check your extensions are compatiblity with the Joomla. Thanks

0