2 Languages Custom.css - Question | JoomShaper

2 Languages Custom.css

MS

Martin Seidl

Helix Framework 10 months ago

Hi Guys, after you helix update I have 2 issues:

  1. the styles in the dropdown main menu have changed: https://mero.arkiadesign.de/ (cant make screenshot of this for it is hover effect) the titles have margin-left, they are not in line with menut items any more.
  2. so far i edited the custom.css in the template options, but there I cant edit any more. do you want me to work on custom.css in the template details? but there I have only one custom.css, but so far I had to have 2 templates, for EN and DE languages.....I am confused how to work on the styles now.
0
14 Answers
Toufiq
Toufiq
Accepted Answer
Senior Staff 10 months ago

Hi there,

Thanks for contacting us. Sorry for the inconvenience. Will you please provide me the Joomla administrator access to check the issue? I will check & get back to you soon.

-Thanks

0
MS
Martin Seidl
Accepted Answer
10 months ago

Hi Toufiq, see below but what is your answer for point 2?

0
Toufiq
Toufiq
Accepted Answer
Senior Staff 10 months ago

Please check now your custom css and menu. Thanks

0
MS
Martin Seidl
Accepted Answer
10 months ago

Hi Toufiq,

  1. the index page is broken now. (I see only contact form and wrong css styles)
    • above main menu the is a background pic which is wrong
  2. the sub main menu misses my grey bottom borders....
  3. there is conflicts all over it seems: https://mero.arkiadesign.de/bausysteme/knotensysteme-1/kk-kugelknoten-system-de.html (probs with z index, it seems)

plz undo those changes!

0
Toufiq
Toufiq
Accepted Answer
Senior Staff 10 months ago

Please check now. Thanks

0
Pavel
Pavel
Accepted Answer
10 months ago

but there I have only one custom.css, but so far I had to have 2 templates, for EN and DE languages

Hi. You can add a page class in the menu item settings or classes for sections in the Layout Builder. And use these classes as parental to create an isolated code.

For greater convenience, you can use custom.css as a master file. Put in the same folder any css files for example custom-en.css, custom-de.css and import them to custom.css. Thus, in custom.css, you will have only this code.

@import "custom-en.css";
@import "custom-de.css";

All the rest code transfer to the appropriate files.

If you are using HU 2 there now, it is possible to create a custom folder and place any number of files there. But it is not very convenient. I prefer the method described above.

0
MS
Martin Seidl
Accepted Answer
10 months ago

sorry Toufiq, but still there are errors:

  1. logo background is different than header background

  2. still the main submenu the border-bottoms of the headings are missing. (firstly it was on the wrong postion and now it is gone completely!) I guess it is this code in my custom.css in template options that does not work any more:

  3. .underlinemenuitem

  4. the headings (for i. black on grey background) on index page are different. I dont know what the heck you were doing....if I knew would be nice....

plz make it as it was before

0
Toufiq
Toufiq
Accepted Answer
Senior Staff 10 months ago

Please share a screenshot that you want to do exactly. Thanks

0
MS
Martin Seidl
Accepted Answer
10 months ago

it is not possible for it is a hover effect. go to https://mero.arkiadesign.de/ hover overmain menu item "Bausysteme", see the first word KNOTENSYSTEME. Under this heading was a border bottom with #ddd solid and 5px. got it?

And on index page I already described. see https://snipboard.io/aYdpj3.jpg heading are black and different styles. I havent deleted the styles but they dont work anymore after your intervention.

0
Toufiq
Toufiq
Accepted Answer
Senior Staff 9 months ago

Please check the menu issue. Thanks

0
MS
Martin Seidl
Accepted Answer
9 months ago

Menu is ok now, headings in index page not. But what has caused all this? what about the logo as mentioned above? What can I do to fix it myself? I mean it was ok before your intervention, you see?

0
MS
Martin Seidl
Accepted Answer
9 months ago

another issue regarding logo on mobile view: https://snipboard.io/kRS5Qe.jpg I cant fix it via template options. Plz let me get a tutorial what I have to do after this update. Just now antohert client of mine whom I installes helix wrote me that he has troubles after update....

0
MS
Martin Seidl
Accepted Answer
9 months ago

...and please ( I have askes this about 5 times !!!) Why do I get all the mails from the posts double/twice?????

0
Toufiq
Toufiq
Accepted Answer
Senior Staff 9 months ago

Except adding css code inside the custom.css file i didn't change anything. Please check the logo issue. Thanks

0