SP Page Builder database update required - failed - Forum | JoomShaper
Staff replied SP Page Builder

SP Page Builder database update required - failed

Asked by WOLF Anlagen-Technik 5 years ago Last activity 5 years ago

Hi, the error warning alway displayed

Database update required
SP Page Builder has been updated. To keep things running smoothly, we need to update your database. We strongly recommend you to take a backup in case anything goes wrong.

After updating the warning appears again and again and again

what should i do?
Frontend editing don´t work now.

5 replies

Ofi Khan Staff

Hello WOLF Anlagen-Technik

In this case, I am providing a patch for you. Inside the maintenance.zip there are two files. But before doing anything, you must take a full site backup for safety.

maintenannce.zip

Please replace the administrator/components/com_sppagebuilder/helpers/maintenance.php file with the maintenance.php file and replace the administrator/components/com_sppagebuilder/sql/install/mysql/install.mysql.utf8.sql file with the install.mysql.utf8.sql from the zip. Hopefully, it will solve the issue.
For your reference: https://www.joomshaper.com/forum/question/7

Best regards

WOLF Anlagen-Technik Asked this

Hi Ofi, thank for your message.
But sorry - the problem is still there. I have replace the two files you send but the warning is still there.

Also my problem with fronted Editing is after updating to com_sppagebuilder_pro_v3.7.9 is not solved. can you please test an say me what is the problem. we paid a lot for years - but pagebilder dont work fine for a while now :( Thanks for your helping!

Best regards
Sebastian

Ofi Khan Staff
5 years ago · edited

Please take a full site backup before applying the fix. Run this SQL Query on your database and check.

ALTER TABLE xxxxx_sppagebuilder CHANGE id id BIGINT(20) UNSIGNED NOT NULL AUTO_INCREMENT;

Replace xxxxx with your database table prefix.

https://prnt.sc/128ernl

WOLF Anlagen-Technik Asked this
5 years ago · edited

Hi Khan,
thank you for your message.

i have make this. But followin warning now appear in SQL Query:

Fehler
SQL-Befehl:
ALTER TABLE e63h4sppagebuilder CHANGE id id BIGINT(20) UNSIGNED NOT NULL AUTOINCREMENT
MySQL meldet: Dokumentation

1062 - ALTER TABLE führt zur Neusequenzierung von autoincrement, wodurch der doppelte Eintrag '1' für Schlüssel 'PRIMARY' auftritt

https://wolf-geisenfeld.de/images/sql-warning.png

The error in Joomshaper is the same. Have you also Login in Backend to see that the "Frontend Editing" is not working. The side site is still loading with no ending.

Ofi Khan Staff

It will be fixed in the next update. Thanks for your patience.

Log in to reply.