Page Builder Database Upgrade Does Not Go Away - Question | JoomShaper

Page Builder Database Upgrade Does Not Go Away

Ben

Ben

SP Page Builder 4 months ago

Hello,

since the upgrade to SPPB 3.7.8 Pro I can find a message in my backend which tells me that it neesd to upgrade the SP Page Builder database.

Some of the error messages look rather severe, like Table #__sppagebuilder does not exist. Table #sppagebuilder_integrations does not exist. (just to name a few).

If I then click on "Update SP Page Builder Database" button it tells me that all upgrades have been performed sucessfully. But the message stays, also after clearing Joomla cache and logging out and back in again.

I can do this over and over again, but nothing visibly happens and SPPB continues to tell me that the database needs to be upgraded.

Any ideas?

Thanks, Ben

1
43 Answers
Toufiq
Toufiq
Accepted Answer
Senior Staff 4 months ago

Hi there,

Please follow the instruction. Download the zip file maintenannce.zip there are two files.

-Replace the administrator/components/com_sppagebuilder/helpers/maintenance.php file with the maintenance.php file from the zip.

-Replace the administrator/components/com_sppagebuilder/sql/install/mysql/install.mysql.utf8.sql file with the install.mysql.utf8.sql from the zip.

Note: The Page Builder has 5 datbase table and id filed will be auto increment. If the auto increment doesn't set, you need to set the auto increment in your id filed.

#__sppagebuilder
#__sppagebuilder_addons
#__sppagebuilder_integrations
#__sppagebuilder_languages
#__sppagebuilder_sections

https://prnt.sc/wc5sil https://prnt.sc/wc5t09 I hope this patch will solve your issue if this is only a MySQL v8 related issue.

-Thanks

4
Kawshar Ahmed
Kawshar Ahmed
Accepted Answer
Senior Staff 4 months ago

Please share your PHP and Mysql version.

Thanks

0
Ben
Ben
Accepted Answer
4 months ago

PHP: 7.3.25 MySQL: 8.0.21-12

0
D56 WebDesign
D56 WebDesign
Accepted Answer
4 months ago

Hello,

I have got the same problem. php: 7.4.3 MySQL: 8.0.22

Tried all kinds of options but until now, no result. Can you please help me with this problem?

Thankx in advance.

0
Kawshar Ahmed
Kawshar Ahmed
Accepted Answer
Senior Staff 4 months ago

Thanks for the information. We will try on our end and share a solution as soon as possible.

Thanks

0
Paul Frankowski
Paul Frankowski
Accepted Answer
Senior Staff 4 months ago

If I may.... So far we noticed that this problem appears only on MySQL v8, not olders. It should be solved in the upcoming update SPPPB 3.7.9. Give us few days.

0
M
Mehmet Serdar Uğur
Accepted Answer
4 months ago

My personal solution : I've edit the file "/administrator/components/com_sppagebuilder/sql/install/mysql/install.mysql.utf8.sql" for table definitions with my own Database Tables Prefix (xxxx): #__sppagebuilder → 'xxxx_sppagebuilder' you can see your database tables prefix on Global Configuration/Server tab.

-1
Ben
Ben
Accepted Answer
4 months ago

Hi Toufiq,

thanks for the maintenance file, this seem to have worked. When I try to set the AUTO_INCREMENT value for the id field in table sppagebuilder, my phpMyAdmin will throw error message "ERROR 1067: Invalid default value for 'created_on'".

Any ideas?

Thanks, Ben

0
Toufiq
Toufiq
Accepted Answer
Senior Staff 4 months ago

If you provide me the Cpanel access. I will share with my developer team. Thanks

This blog post will help you to share the hidden content https://www.joomshaper.com/blog/introducing-more-optimized-and-private-support-forum

0
Ben
Ben
Accepted Answer
4 months ago

My provider is not using cPanel. What exactly do you need: Joomla backend acess? MySQL database access (this will be going via PHPmyAdmin)? Somthing else?

0
Toufiq
Toufiq
Accepted Answer
Senior Staff 4 months ago

Database access. Thanks

0
Ben
Ben
Accepted Answer
4 months ago

I have added the database access to the hidden content area of this question. Please kindly let me know if you can see it.

0
Toufiq
Toufiq
Accepted Answer
Senior Staff 4 months ago

I have informed to our team. I hope they will help you within 72 hours. Thanks

0
Toufiq
Toufiq
Accepted Answer
Senior Staff 4 months ago

Here is the update database. Create a new database name or delete your existing database all tables.

0
M
Mehmet Serdar Uğur
Accepted Answer
4 months ago

AUTO_INCREMENT trick worked perfectly. Now I can add new pages. Thank you

0
Toufiq
Toufiq
Accepted Answer
Senior Staff 4 months ago

Glad to know that your problem solved. Please mark as resoved your forum post. Thanks

0
Ben
Ben
Accepted Answer
4 months ago

Hi,

I have downloaded the SQL files. Please urgently remove them from this site as they are visible publicly.

Thanks, Ben

0
Kawshar Ahmed
Kawshar Ahmed
Accepted Answer
Senior Staff 4 months ago

From the future, if anything sensitive then use private question.

Thanks

-1
Toufiq
Toufiq
Accepted Answer
Senior Staff 4 months ago

Please check now. Thanks

0
Ben
Ben
Accepted Answer
4 months ago

@Toufiq: Thanks, files are gone.For the future, I would prefer exchanging complete SQL dumps via e-mail instead of a public support forum. :-) All works fine now, thanks for your support.

Best regards, Ben

0
Toufiq
Toufiq
Accepted Answer
Senior Staff 4 months ago

Please read the blog post. It will help you to understand how works the new forum.

https://www.joomshaper.com/blog/introducing-more-optimized-and-private-support-forum

0
regioprint
regioprint
Accepted Answer
4 months ago

I cannot add new pages A few days before, you send me a solution via supportticket. Thanks for the maintenance file, this seem to have worked.

BUT: I cannot add new pages, or save and add section from my site.

When I try to set the AUTO_INCREMENT value for the id field in table sppagebuilder, my phpMyAdmin will throw error message "ERROR 1067: Invalid default value for 'created_on'".

Helix 2.5.8 Joomla 3.9.23 SPPB 3.7.7 php: 7.3 database: MySQL 8.x

best regards regioprint Happy New Year

0
Toufiq
Toufiq
Accepted Answer
Senior Staff 4 months ago
  1. Download your database
  2. create a database in your localhost
  3. Import the database in your localhost
  4. Click on the SQL option from your phpmyadmin
  5. SET sql_mode = ''; use this code https://prnt.sc/we4h1n
  6. Then try to change the auto increment
0
regioprint
regioprint
Accepted Answer
4 months ago

Hello Toufiq, i am not sure with sql. Therefore i will wait for an update of SPPB, which will solve the problem, that I cannot add new pages, because i am using MySQL 8.* Thanks best regards

1
B
BisDom
Accepted Answer
4 months ago

Hi Taufiq,

maintenance file did not work for me. im worrying it might have altered many tables then before. please advise proper solution.

1
Toufiq
Toufiq
Accepted Answer
Senior Staff 4 months ago

@BisDom please create a new forum post and share your credentials(administrator access, hosting access).

0
regioprint
regioprint
Accepted Answer
3 months ago

Hello Toufiq,

I cannot add new pages. Helix 2.5.8 Joomla 3.9.23 SPPB 3.7.7 php: 7.3 database: MySQL 8.x

Your solution: Download your database create a database in your localhost Import the database in your localhost Click on the SQL option from your phpmyadmin SET sqlmode = ''; use this code https://prnt.sc/we4h1n Then try to change the auto increment

But i am not able to do this. Please help me in another way.

Paul says: If I may.... So far we noticed that this problem appears only on MySQL v8, not olders. It should be solved in the upcoming update SPPPB 3.7.9. Give us few days.

best regards

regioprint

0
Paul Frankowski
Paul Frankowski
Accepted Answer
Senior Staff 3 months ago

Sorry but you still have to wait for new version, it wasn't fixed in 3.7.9 otherwise you would read that info in changelog. Please try to use lower version of database.

But as Toufiq said with can test new code using your site to improve SPPB sooner.

0
MA
Marco Antonio Flores Artica
Accepted Answer
2 months ago

thanks , this work for me..

Please follow the instruction. Download the zip file maintenannce.zip there are two files....

0
P
Peter Procházka
Accepted Answer
2 months ago

I'm using version 3.7.9 and the problem remains. I can't add a new page.

0
Toufiq
Toufiq
Accepted Answer
Senior Staff 2 months ago

Download and install this zip file

maintenannce

-1
TB
Tim Bugler
Accepted Answer
2 months ago

Updating the maintenance files and changing fields to auto-increment doesn't work (Mysql 8). It tells me it made all the necessary changes, but when I check the database, nothing has been updated aside from auto-increment has been turned off. I am continually prompted to update the database.

I just purchased this extension and it's a little disappointing that I cannot actually use it - in particular add new pages. There were no indications that it does not work with mySQL8. Is there a fix that works for eveyone as the supplied maintenance files and database alterations do not work in my case.

0
Paul Frankowski
Paul Frankowski
Accepted Answer
Senior Staff 2 months ago

There were no indications that it does not work with mySQL8.

We put this information (warning) in SPPB documenation. Really sorry, we have hope that upcoming update will improve it.

0
F
Frank
Accepted Answer
1 month ago

Hi

0
Toufiq
Toufiq
Accepted Answer
Senior Staff 1 month ago

@Frank Please provide me the Joomla administrator access & database access. I will check & get back to you soon. Thanks

0
F
Frank
Accepted Answer
1 month ago

hi.

-1
Toufiq
Toufiq
Accepted Answer
Senior Staff 1 month ago

@Frank please ready my last reply carefully.

Note: Site URL and database access missing

0
ER
Elizabeth Rodriguez
Accepted Answer
1 week ago

Hello! It seems I have the same problem, or at least a very similar one.

I get this message:

Database update required SP Page Builder has been updated. To keep things running smoothly, we need to update your database. We strongly recommend you to take a backup in case anything goes wrong.

So I updated it, but then I keep getting the same message:

Database update required SP Page Builder has been updated. To keep things running smoothly, we need to update your database. We strongly recommend you to take a backup in case anything goes wrong.

So I updated it, again, and still getting that message. Over and over again.

Do you think the zip file will help me too?

Thank you very much for your time!

0
Toufiq
Toufiq
Accepted Answer
Senior Staff 1 week ago

@Elizabeth Rodriguez, Please create a new post with your administrator access. Thanks

0
F
Frank
Accepted Answer
1 week ago

hello sent

0
Paul Frankowski
Paul Frankowski
Accepted Answer
Senior Staff 1 week ago

@Frank, we need access as Super User !!

0
J
jakob.beyeler
Accepted Answer
1 week ago

Hi dear Joomshaper Team,

when will you finally fix this issue? It would be a lot easier for you to provide an update with the issue fix, than to laboriously answer every single person here in the forum the same thing over and over. It is not only a waste of time for you, but also annoying for the users. Don't get me wrong, I don't want to blame you, I want to show you an easier way for both sides to find a better solution to a very annoying problem. I hope something will happen soon in this direction.

0
Toufiq
Toufiq
Accepted Answer
Senior Staff 1 week ago

We are working for PHP 7.4 and mysql 8. I hope dev team will release it soon. Thanks

0