Hi,
I updated many sites to joomla 4.1.2 from 3 ... .
But at the last site there is no chance.
After the update th front and backend have a mistake.
Infomation:
JInstaller: :Install: SQL-Fehler Duplicate entry '1' for key 'PRIMARY'
What can I do?
Hi,
I updated many sites to joomla 4.1.2 from 3 ... .
But at the last site there is no chance.
After the update th front and backend have a mistake.
Infomation:
JInstaller: :Install: SQL-Fehler Duplicate entry '1' for key 'PRIMARY'
What can I do?
I can send you akeeba backup, so you can see.
Hello
Apologies for the inconvenience. This kind of error actually means that you have been migrated to a database where fragments from previous unsuccessful attempts may remain. Can you try using a new database or clean the old one when restoring after unsuccessful attempts?
If you are testing the Joomla 4 upgrade, and you test and re-test on the same database, kindly make sure that you delete everything between each test.
Otherwise, the installer re-creates and re-inserts the same records on the tables that were created in the previous test, and then it fails with the error that you mentioned: "JInstaller: :Installer: Found SQL Duplicate entry '1' for key 'Primary'"
Additionally, if there was a previous failed attempt to upgrade to Joomla 4, there could be inconsistencies in the tables too.
Hello,
I made a new Database more times. But I does not help.
Can you help me?
Best jörg
Hi Ariba,
once again. I try more times more, but there is a mistake. Can you check it?
The last days, I update more sites... . But here is a big problem and I do not know, what can I do...
Best Joerg
Hello
Please share the Akeeba Backup here in ZIP format.
Hi Ariba!
Thank you!
Here you find the Link.
Best Joerg
Hi Ariba,
how are you? Have you some news for me about the mistake?
Best Jörg
Hi there,
Sorry for the inconvenience. Will you please provide me the Joomla administrator access to check the issue? I will check & get back to you soon.
-Thanks
Hello!
For your information. I have completely changed the site now from Floox to Template helix.
There are now already created about 20 attempts.... .
I also put a jpa. File to the check to the download ready ...
Thanks for your help.
Best Jörg
Do you know how to unarchive JPA file? I don't have any idea.
Hello Toufig,
I take the kickstart.php and the englisch language pack on the server or you download it at akkeba.
The kickstart only works at this moment at php 7, 4 not at php 8,0 ... I try yesterday ...
More information directly from akkeba.
Thank you for your buisness.
Yes, I also found this issue. But, I don't think this issue occurred for our product. Thanks
Hello Toufiq,
I thought that you could use this to set up the website on a xampp server and find the error.
If this service can not take place I have to completely rebuild the page.. .
Thanks.
Jörg
Please check the latest backup
Hi!
Update is done ... Same problem..
After update there is the first information.
Joomla!-Versionsaktualisierungsstatus
Hinweis Die Site wurde aktualisiert. Die neue Joomla!-Version ist jetzt: 4.1.2.
Backend is "damaged".
You can see on the admin ...
Did you try new install or did you try update on your existing?
Hello Toufig,
The site is broken after an update from an exsiting Joomla 3 to Joomla 4 site.
The jpa file is a copy of the site.
Download this zip file and run on your localhost first. If you think this package is works fine. Then you can move it live server.
https://drive.google.com/file/d/16fMwHR2ZAa3yctnP5rn7zm6YlwB7ijQj/view?usp=sharing
Hi Toufiq!
Please read hidden Content.
Best Jörg
Can you give me zip file of akeeba backup?
https://drive.google.com/file/d/1HwEmKAzw-uVWQHdASGHU31nJaJKBSR56/view
Hi Toufiq,
thank you for your e-mail. Please find the file on the server.
Best Jörg
I think this issue comes from Joomla. Cause, I have tried to update the Joomla include page builder and exclude page builder. But, Same error occurred. You need to contact with the Joomla forum. Thanks
Hello Toufig,
thank you.
Best Jörg
You are most welcome