Unable to delete product images - Forum | JoomShaper
Solved EasyStore

Unable to delete product images

Asked by Peter Konoy 1 year ago Last activity 1 year ago

I cant delete the images i uploaded in error to a product. A red square appears saying "You don't have the right permission". Im Super Admin, and i created the product myself. I tried uploading a second image but i cant delete any of them. Please advice.

Accepted answer

Marked as the solution
Ziaul Kabir Staff
1 year ago · edited

Please go to this location:

administrator/components/com_easystore/src/Traits/

and replace Media.php file with the attached file. You need to unzip the file and then replace.

Media.php.zip

It should be fixed this time.

Peter Konoy Asked this

Awsome! Thank you so much :)

Ziaul Kabir Staff

You are welcome.

1 more reply

Ziaul Kabir Staff

Hello Peter,

Thanks for reaching out to us. I am apologizes for this issues. Please, check this post: https://www.joomshaper.com/forum/question/35488.

And let me know is it help or not?

Thanks,

Best Regards,

Peter Konoy Asked this

Unfortunatly the link returns "500 - You are not authorized to see this question
Sorry, we can't find the page that you're looking for."

Ziaul Kabir Staff

Hello,

Could you please check if ModSecurity is enabled on your hosting server? If it is, kindly disable it. Additionally, ensure that the file permissions for your media files are set correctly, the media folder should have permissions of 755, while the files should be set to 644. Also, please verify that the server is configured to allow the necessary CORS (Cross-Origin Resource Sharing) permissions.

Thank you!

Peter Konoy Asked this

Thank you. Unfortunately i do not know how to check ModSecurity an CORS. The permissions are set up as you mention though and that did not help.

Ziaul Kabir Staff

To disable ModSecurity, Please, contact with your hosting provider, They can help you with that.

Thanks,

Peter Konoy Asked this

I have chattet with one.com's support, and they do not offer to remove ModSecurity 😕

Stuart Clark

@Ziaul Kabir ModSecurity has NOTHGING to do with this! The link you posted returns the 500 error. Try clicking on it yourself!

The inability to delete product images from EasyStore 1.4.1 is due to a coding error introduced by JoomShaper. The fix can be found here: https://www.joomshaper.com/forum/question/36053

(yes, I checked the link worked)

Peter Konoy Asked this

Thanks Stuart :)

Log in to reply.