Helix Ultimate 1.1.3 update fails - Forum | JoomShaper
Staff replied Helix Framework

Helix Ultimate 1.1.3 update fails

Asked by Allen 5 years ago Last activity 5 years ago

Tried to update through Joomla update. Fails:

Failed to extract file: index.php

Downloaded Helix Ultimate 1.1.3 Template from Joomshaper. Warning:

Copy file failed

Joomla update still shows that I need to update Helix. What now?

23 replies

Rashida Rahman Staff

Hi there!

Sorry for the inconvenience.

Would you please give me your admin access to check the issue?

Best Regards

Allen Asked this
5 years ago · edited

Provided in Hidden Content

Paul Frankowski Senior Staff
5 years ago · edited

Indeed you have weird message during installation, but it looks that plugin & template was updated.
I checked xml files.

In Akeeba Admin Tools click "Fix permissions" from time to time, it may help.

Allen Asked this

I ran the Akeeba permissions fix and manually reinstalled the update. I still get the same warning:

Warning
Copy file failed

I tried updating through Joomla update, and I still get the same error:

Failed to extract file: index.php

I cleared the update cache and let it rebuild in control panel. The update notification is still there.

I went to extensions management, and it still shows shaper_helixultimate as 1.1.2 instead of 1.1.3, which is shown in Helix Ultimate itself if I open up template options.

Now what? I suspect the "Copy file failed" warning points to a culprit somehow.

Paul Frankowski Senior Staff

Just change in database number from 1.1.2 to 1.1.3 - as you know all files are new.

Sometimes Joomla goes crazy. I had this same with many other extensions in the past.

Allen Asked this

Thanks. I am not familiar with which table this is, and I don't want to guess. Please advise.

What about the file copy warning?

Allen Asked this

I found it in _extensions.

I changed "version":"1.1.2" to "version":"1.1.3".

I cleaned Joomal Update cache.

Joomla update no longer shows the template as needing update.

Rashida Rahman Staff

Glad to know that you have sorted things out, Allen:)

Allen Asked this
5 years ago · edited

Just tried to update again today from 1.3 to 1.4. The update fails with error:

Failed to extract file: index.php

I tried to manually install. Fails with warning:

Warning
Copy file failed
×
Message
Installation of the plugin was successful.

When I go to Template Options for Helix Ultimate, I see version 1.3.

Version 1.4 is not installing.

I ran Akeebe Permissions Fix and DB Optimization. Still fails.

PageBuilder pro updated with no problem, so permissions must really be okay.

Paul Frankowski Senior Staff

If somehow your Joomla doesn't allows you to update extensions nor templates - you have to download Helix Quickstart and manually - using FTP tool - upload helix ultimate template and plugin from it.

Log in to reply.