EasyStore Fail When Use Payment RedSys - Forum | JoomShaper
Solved EasyStore

EasyStore Fail When Use Payment RedSys

Asked by Riojana de Telecomunicaciones 1 year ago Last activity 5 months ago

Good morning,
We are having a problem with the Redsys payment gateway when implementing it in the store.
Whenever we try to make a payment, we get an error from Redsys (SIS0434).
We have contacted the Redsys support team and they have informed us that the problem is that the value “DS_MERCHANT_ORDER” they receive is only one character long, when it should be between 4 and 12 characters.
The Redsys data we have entered is correct, so we don't know how to fix it. We need to get the store up and running urgently.

I have seen that we probably have the same problem that they had here: https://www.joomshaper.com/forum/question/36708?order=newest

Thank you so much

Accepted answer

Marked as the solution
Ofi Khan Staff

I have found the solution. On the plugin settings, Live Terminal value should be 001. Please check the payment gateway now.

https://prnt.sc/ScbAfvxQXbCf

13 more replies

Ziaul Kabir Staff

Hello Riojana,

Thank you for reaching out to us.

I sincerely apologize for the inconvenience. Our development team is currently reviewing the issue.

I will update you as soon as we have a response.

Thank you for your patience and understanding.

Best regards,

Ofi Khan Staff

Hello Riojana de Telecomunicaciones,

Thank you for reaching out to our technical support forum. I’m sorry to hear about the trouble you’re experiencing.

I have checked the Redsys payment and it works fine on our local evnironment. Please share your administrator access here to check your issue. Use the Hidden Content box to share the credentials. Make sure that you have a full site backup before sharing.

Best regards

Riojana de Telecomunicaciones Asked this

Hello,

I have created a user for you.

Thanks for you help

Ofi Khan Staff

Thanks for the access. I am investigating your issue. Allow me some time.

Ofi Khan Staff

I have asked the developer team for help. I need your database access to fix the issue.

Please allow me the access.

Riojana de Telecomunicaciones Asked this

Hello,

Here is the access. It’s a Plesk panel. To access the database, you need to go to the subdomain tienda.botasrioja.com and then navigate to Dashboard > Databases.

In the new window, select tiendariojbota, which is the assigned database. By clicking on the phpMyAdmin icon, you will be taken directly there.

If needed, I can also provide the direct connection details.

Best regards.

Ofi Khan Staff

Thanks for the database access. After modifying the easystore_orders table in the database, the error is changed. But the issue is not solved. I am taking an Akeeba Backup of the site to check it on my localhost. I will update you as soon as I get the fix.

Riojana de Telecomunicaciones Asked this

Thank you very much, Ofi, for your help and for the quick response in solving the issue.

Ofi Khan Staff

You are welcome 😊

If the answer resolved your query, you can mark it as accepted to close the post and guide others with similar questions. You’ll find a button to accept answers below each comment.

If you need further assistance, feel free to let us know!


I have a humble request. It would be very kind of you if you can manage some moment to give us feedback on 

  1. Joomla Extension Directory
  2. TrustPilot

This will inspire us to improve.

Riojana de Telecomunicaciones Asked this

Hi, we're seeing this error again (SIS0434) in another store using easyStore. Could you explain how you resolved it?
We've already changed the Live Terminal to 001. Did you make any changes to the database?

Log in to reply.