Helix - Site Template Style save error - Forum | JoomShaper
Solved Templates

Helix - Site Template Style save error

Asked by FJN 1 year ago Last activity 11 months ago

Hello,

We've suddenly started receiving a save error in Helix Site Template Styles: "Error: Undefined." I've been able to bypass the Joomla admin error and make changes directly in the Database, but obviously that's a bandaid.

  • Joomla 5.3.4
  • Helix Ultimate & Framework 2.1.3
  • PHP 8.2
  • DB 10.11.14 Maria

Any ideas or othes with the same experience?

Accepted answer

Marked as the solution
Ziaul Kabir Staff

Now, I see this. This is server issues.
Please, contact with your server administrator to fix this.

Thanks

7 more replies

Ziaul Kabir Staff

Hello,

Thanks for reaching out to us. Could you please share temporary administrator access to your Joomla backend? You can provide the credentials securely in the hidden content section. Also, please take a full backup of your site before we make any changes.

Once I have access, I’ll investigate further and see what’s causing the issue. Let me know once you’ve shared the details!

Best regards,

FJN Asked this

Great, thank you. The details to view the Staging site and log in are in the hidden content.

Ziaul Kabir Staff

Hello,

The website you provided is currently not loading on my end.

Please double-check the URL and share the correct one so I can take a closer look.

Thanks,

FJN Asked this
11 months ago · edited

Oh, my goodness. I triple checked everything and still messed up. My apologies. Correct URL and all details in Hidden content. I appreciate your patience.

Incidentally, since this is a staging site, Joomla's default Cassiopeia template is still enabled, but not the default, so you're welcome to test using it.

The steps, just to be clear, are: System -> Site Template Styles (Site) -> shaper_helixultimate - Default -> Template Options. Error occurs on "Save."

Note that the site has several custom CSS files, but we have no problem saving those or working in the "Site Templates" area. It seems only to be with Helix's Site Template Styles.

FJN Asked this
11 months ago · edited

Network tab in Inspector shows 403 error on: /administrator/index.php?option=com_ajax&request=task&helix=ultimate&id=12&action=save-tmpl-style&format=json&helix_id=12

Does this help uncover what's going on?

ETA: The error has to do with saving when there's Custom Code in "Before </head>" field. I removed our tracking code, leaving that field empty, and Helix saved fine. However, adding the code back is now impossible since the template options won't save with a value in that field.

The code we need loaded in that field is in the hidden content

Ziaul Kabir Staff

Please, check now, I have add this. You have missed to add script start tag.

Thanks

FJN Asked this

Thanks for checking, but it's still not working. The tracking code does have the start script tag. <script>. It's there. We still cannot save the Template Options with a value in Custom Code, Before </head>.

Would you mind checking again? Can you try adding the code I provided in the hidden content?

Thanks in advance.

FJN Asked this

This took some time to finally get back around to. The issue was that the host's PHP Modsecurity was enabled and blocking some save requests. Thanks for pointing us in the right direction. We're fixed now.

Log in to reply.