joomla 4 | Upload Logo with Ultimax Template doesn´t work - Forum | JoomShaper
Solved Helix Framework

joomla 4 | Upload Logo with Ultimax Template doesn´t work

Asked by Michael Ko. 5 years ago Last activity 5 years ago

Hi.

i have a Problem with a Upload Logo File in Helix Ultimate Framework.
COM_SPPAGEBUILDER_MEDIA_MANAGER_MEDIA_TOTAL_SIZE_EXCEEDS

I increase the capacity in Joomshaper and joomla of 120 MB Media files.

Pleas help. Thanks.

Accepted answer

Marked as the solution
Paul Frankowski Senior Staff
5 years ago · edited

Hi,
If I may...

I had this same problem, and inside PHP settings you have to change one value only.

In cPanel - MultiPHP INI Editor - memory_limit -
-- if you have -1 (nolimit) as probably now - upload doesn't work, but if you set 128M or 256M or 512M -- then it's fixed.

and yes, I agree we have to fix "if" syntax inside helix source code.

5 more replies

Muntasir Sakib Staff

Hello there,

I guess you are using Helix Ultimate 2.x.x version, right? How big is your logo and which format are you using?

Looking forward to hearing from you soon.

Michael Ko. Asked this
5 years ago · edited

The Logo is 6 Kb. Format JPG | Helix ultimate for Joomla 4

The Problem is here
COM_SPPAGEBUILDER_MEDIA_MANAGER_MEDIA_TOTAL_SIZE_EXCEEDS

Michael Ko. Asked this

The Problem is here:

$error = false;
$params = ComponentHelper::getParams('com_media');
$contentLength = (int) $_SERVER['CONTENT_LENGTH'];

                            $mediaHelper = new \JHelperMedia;
                            $postMaxSize = $mediaHelper->toBytes(ini_get('post_max_size'));
                            $memoryLimit = $mediaHelper->toBytes(ini_get('memory_limit'));

                            // Check for the total size of post back data.
                            if (($postMaxSize > 0 && $contentLength > $postMaxSize) || ($memoryLimit !== -1 && $contentLength > $memoryLimit))
                            {
                                    $report['status'] = false;
                                    $report['message'] = Text::_('COM_SPPAGEBUILDER_MEDIA_MANAGER_MEDIA_TOTAL_SIZE_EXCEEDS');
                                    $error = true;
                                    echo json_encode($report);
                                    die();
                            }

                            $uploadMaxSize = $params->get('upload_maxsize', 0) * 1024 * 1024;
                            $uploadMaxFileSize = $mediaHelper->toBytes(ini_get('upload_max_filesize'));

                            if (($file['error'] === 1) || ($uploadMaxSize > 0 && $file['size'] > $uploadMaxSize) || ($uploadMaxFileSize > 0 && $file['size'] > $uploadMaxFileSize))
                            {
                                    $report['status'] = false;
                                    $report['message'] = Text::_('COM_SPPAGEBUILDER_MEDIA_MANAGER_MEDIA_LARGE');
                                    $error = true;
                            }
Michael Ko. Asked this
5 years ago · edited

.

Muntasir Sakib Staff

Hello there,

Please share your administrator access with us and the logo image location that you want to upload so that we can have a look from our end.

Thanks!

Log in to reply.