Technical Requirements | MegaInc - Documentation | JoomShaper

MegaInc

Updated Last: 22 July 2019

Technical Requirements

Installing QuickStart with demo content requires server, it can be installer also locally on your computer with WAMP/JAMP/XAMPP/MAMP software.

PHP settings

The minimum and recommended PHP requirements*:

  • PHP 7.0.x, PHP 7.1 or PHP 7.2 (64 bit version)
  • MySQLi 5.5, 5.6 or 5.7+
  • upload_max_filesize = 4M (or more)
  • memory_limit = 128MB (256MB or more suggested)
  • max_execution_time = 180 (300 or more suggested)
  • PHP upload_max_filesize = 4M or more
  • Magic Quotes GPC - Off
  • cURL library - your server must work with curl or url_fopen.
  • OpenSSL - must be enabled.
  • PHP file_get_contents() function - must be available/unlocked.

Note: Support for PHP 5.4 and PHP 5.5 ended, also PHP 5.6 is only partly supported.

* Those values can be changed in php.ini or .htaccess file. Please contact your web hosting service provider to be sure that your server complies with the requirements or to ask them where/how to change PHP settings. There are some less demanding situations where Template and SPPB will perform quite well in weaker PHP settings.

Remember to restart Apache (localhost only) after configuration changes.

Browsers support

We suggest using the latest version of  Safari, Chrome, Opera, Firefox, and Brave browser to edit SPPB content.

  • Design support for Edge (Windows 10) may be limited in certain areas.
  • Design support for IE11 is limited in certain areas, please update to Edge.
  • Microsoft will no longer provide security updates or technical support for older versions of Internet Explorer. Using older versions of Internet Explorer may expose you to potential security risks. IE11 browser graphic engine is not updated/improved since 2015.

Note! Internet Explorer version 10 and older are NOT supported anymore, even by Microsoft company.