Sp Page Builder Keeps Hanging When Showing Page Layouts - Question | JoomShaper

Sp Page Builder Keeps Hanging When Showing Page Layouts

S

salamandro

SP Page Builder 2 weeks ago

The SP Page Builder Pro keeps hanging, when trying to display "Page Layouts" or "Add Section" in the Backend Page Editor. The same happens, when I try to active the "Blocks" or "Layout" menu in the Frontend Editor. The SP Page Builder specific Addons are showing in the Frontend editor and I can add them to pages. The SP Page Builder Pro License Info is correctly entered in my opinion.

I tried several fixes described for similar problems in the joomshaper forum:

But the problem persists.

It is a fresh JOOMLA 4 install, with Helix Ultimate Template and Plugin and SP Page Builder installed as extensions later. JOOMLA ist is self hosted on ovhCloud.

Versions: Joomla 4.1.2 Helix Ultimate Plugin 2.0.8 Helix Ultimate Template: 2.0.8 SP Page Builder Pro 3.8.6

0
4 Answers
Toufiq
Toufiq
Accepted Answer
Senior Staff 1 week ago

Hi there,

Thanks for contacting us. Sorry for the inconvenience. Please disable the rocket_loader from your cloudflare settings or disable the mod_security from your server. Then check again.

-Thanks

0
E
easybreather
Accepted Answer
1 week ago

Do you get the Pizza Wheel or just Wheel of death? I have this problem too and regularly ask for help but @Toufiq has looked and "no problem found" @see https://www.joomshaper.com/forum/question/13864#qa-answer-67507

This is definitely one of the symptoms... https://archive.joomshaper.com/forums/update-latest-sp-page-builder-pro-3-4-9-gone-templates-layout-and-add-section-library

I was using Opera, but this happens in Chrome too. I think it is a problem of sequence - the joomshaper licence is (somehow) reset to my admin account details and then when you attempt to access the page this causes a cyclic login failure which renders the page "locked" but you can't re-edit (but if you just click on it - not preview or live edit - it is returned back to "not locked").

BUt after this, you cannot ever see the page again. It is perfectly fine to "view" but no more editing :(

I really would like an answer here as my confidence in using Joomshaper is shot :(

0
S
salamandro
Accepted Answer
1 week ago

Thanks for your inputs easybreather. It turned out, that - contrary to the claim in my initial post - I hadn't correctly disabled the firewall on my webhost. On my hoster ovhCloud I had to disable the firewall in the .ovhconfig file in the subdomain specific site folder. With the firewall disabled, the problems with adding sections and showing page templates disappeared immediately. Thank you very much for the hint Toufiq.

0
Toufiq
Toufiq
Accepted Answer
Senior Staff 5 days ago

You are most welcome. Will you please spend some to write a review about our product and support quality? 

https://extensions.joomla.org/extension/sp-page-builder/

0